Pppoe issue over SFP GPON with Timeout waiting for PADO packets

I am having an issue with pppoe over a vlan on the fibre module.

Here is a log of what I get.

2018-01-16T17:48:40-05:00 notice netifd: Network device ‘eth1’ link is up
2018-01-16T17:48:40-05:00 notice netifd: VLAN ‘eth1.35’ link is up
2018-01-16T17:48:40-05:00 notice netifd: Interface ‘wan’ has link connectivity
2018-01-16T17:48:40-05:00 notice netifd: Interface ‘wan’ is setting up now
2018-01-16T12:48:40-05:00 info kernel: [ 56.981047] mvneta f1034000.ethernet eth1: Link is Up - 1Gbps/Full - flow control off
2018-01-16T12:48:40-05:00 info kernel: [ 56.981068] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
2018-01-16T17:48:41-05:00 err kresd[1998]: [priming] cannot resolve ‘.’ NS, next priming query in 10 seconds
2018-01-16T17:48:50-05:00 info pppd[2975]: Plugin rp-pppoe.so loaded.
2018-01-16T17:48:50-05:00 info pppd[2975]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
2018-01-16T17:48:51-05:00 notice pppd[2975]: pppd 2.4.7 started by root, uid 0
2018-01-16T17:49:01-05:00 info /usr/sbin/cron[3049]: (root) CMD (/usr/bin/rainbow_button_sync.sh)
2018-01-16T17:49:02-05:00 err kresd[1998]: [priming] cannot resolve ‘.’ NS, next priming query in 10 seconds
2018-01-16T17:49:06-05:00 warning pppd[2975]: Timeout waiting for PADO packets
2018-01-16T17:49:06-05:00 err pppd[2975]: Unable to complete PPPoE Discovery
2018-01-16T17:49:06-05:00 info pppd[2975]: Exit.

I have tried with the cloned mac address but still the same issue. I also tried bad password, then good password. You will notice that the providor (Bell Canada) required vlan 35.

Any help would be greatly appreciated


I have tried changing mtu size, but still no luck. What gives? If I try on another router, it works. Is this a bug on the omnia build?

Hi, Daniel, any news?

I am currently trying to connect Omnia to Vodafone Optical fibre using HUAWEI EchoLife HG8010H as terminal, but no success.

Receiving error message:

…Timeout waiting for PADO packets.
… Unable to complete PPPoE Discovery.
… Exit.

From Vodafone I got info, the setup should reflect:

  • GPON 802.1P with priority 0
  • VLAN ID 848

Honestly I have no idea, how to set it up in Omnia.

I tried with every update with no luck. Only way I got it to work was by using a media converter outside of the Omnia.