Portforwarding problem (Port 25565)

Hey im trying to open the port 25565. so Friends can join my Game server that i host on my computer.
But if i check the port with as example https://www.yougetsignal.com/tools/open-ports/ it shows as closed. I atached a picture of my setting. it would be nice if someone could look over it. thx

Anyone correct me if i’m wrong but your internal IP address starts with ‘212’? That doesn’t look correct. You probably entered its WAN address.
The LAN internal IP address of your game server should be entered here (and usually start with 192). It helps to give your game server a fixed IP address.

Second picture

…and does it work?

You will probably be behind NAT - you probably don’t have a (fixed) public IP.

Opening port and port-forwarding are not the same stuff.

You have to open the port on “wan/wan6” interface first (network->firewall->traffic rules -> open-port) there just open 25565 in wan zone.Once done(save-and-apply), go to "(network->firewall->port-forwarding) where you redirect wan:port to lan:port.
Here are pictures from my ‘plex’ rules
Open-port-rule:


Forwarding:

I disagree with that. If the service (server) is running on the router, then it is enough to open the port. However, if it is running outside the router, port forwarding must be performed and nothing else can be opened.

EDIT: Second picture - is right.

1 Like

I am not routing guru (some stuff is still black-box for me :slight_smile: .

But from my experience with several services accessible from internet/vpn i have to have open-port-rule together with port-forward-rule active. If one of them is “disabled”, I can’t reach related service outside the lan. So from my point of view, you have to open port which is later forwarded.

I have this setup since some time (so maybe some TOS update make this obsolete setup- …) If there is some trick in routing setup which do not require open-port rule, can you share the know-how/tips-und-tricks?

I’m not a professional user :slightly_smiling_face:. I know this setting for sure. It’s more complicated over VPN bridge (+ route command, etc.).

I don’t know any trick if the service is working on a router - if listening 0.0.0.0, then just opens the port. If the service is running in LAN (approx. 192.168.1.0/24) then port forwarding must be performed. It’s a bit different with a transparent proxy, but I wouldn’t confuse it right now.