Podivné chování utility rainbow po upgradu na TOS 6.0.1

Kromě toho, že z nějakého důvodu došlo k přejmenování LED (indicator-2 místo usr2 apod.), tak i celkové chování je zvláštní (i po restartu).
Například “rainbow indicator-2 red enable” změní jas všech LED na maximální hodnotu a rozsvítí i LED wlan-3.
Obecně při jakékoli akci se i objevuje tato chyba :

root@turris:~# rainbow indicator-2 disable
Command failed: Not found
Command failed: Not found

Proto by mě zajímalo, jestli dělám něco blbě nebo je tam stále nějaký problém, který bude vyřešený v dalších upgradech? Díky.

1 Like

Taky s tím mám problém, předtím jsem měl všechny LED nastavené na červenou barvu což po updatu přestalo fungovat a nastavit to znovu nejde. A to ani přes command rainbow :confused: - zobrazuje se mi stejná hláška jako Pavlovi výše. Zatím to vyřešila páska :slight_smile:

Podle myho pozorovani to nastaveni Rainbow se pouzije jen v pripade ze je dana LED rovnez nastavena v Systemu. Pro uplne zhasnuti mi funguje nasledujici:

System:

Rainbow:
image

Ještě jsem si s tím trochu hrál, chování se potom zlepšilo. Konkrétně jsem v LuCI System/Software odinstaloval vše, co mělo v názvu rainbow, celkem 4 systémové balíčky. Pak se stačí přepnout do reForis a v Package Management/Updates se ty balíčky automaticky nabídnou k opětovné instalaci. Pak jsem to ještě radši restartoval. Nakonec jsem zkusil jas LED nastavit pomocí té utility “rainbow brightness 1”. Nevím jak to přesně funguje, každopádně zmizely tyto problémy :

  1. po restartu LED nesvítí maximálním jasem, zůstává předchozí nastavení
  2. utilita rainbow už nemění jas všech LED na maximum při jakékoli akci

Co se týká chyby “Command failed: Not found”, ta nezmizela, ale stačí spustit rainbow s debugem (parametr -x) a je vidět problém. Ten je v utilitě /etc/init.d/rainbow-animator, kdy některé parametry nefungují :

‘[’ -x /etc/init.d/rainbow-animator ‘]’
/etc/init.d/rainbow-animator reload
Command failed: Not found

root@turris:~# /etc/init.d/rainbow-animator
Syntax: /etc/init.d/rainbow-animator [command]

Available commands:
start Start the service
stop Stop the service
restart Restart the service
reload Reload configuration files (or restart if service does not implement reload)
enable Enable service autostart
disable Disable service autostart
enabled Check if service is started on boot
pause Pause animator loop
running Check if service is running
status Service status
trace Start with syscall trace

Zkusil jsem “/etc/init.d/rainbow-animator restart” a najednou potom funguje i “/etc/init.d/rainbow-animator reload”. Dělá to na mě dojem, jako nějaký bordel po instalaci.

1 Like

Intenzitu jasu nastavuji hardwarovym tlacitkem vzadu na Turrisu 1.1. Jestli ho ma i Omnia netusim.

Tak samozřejmě, že tam to tlačítko je, Omnie ho má zepředu. Ale o to nejde, je otravné to po každém resetu znovu nastavovat tlačítkem. Od toho tam je rainbow, aby se to dalo pohodlně měnit, pokud funguje správně.

Jestli ho ma i Omnia netusim.

Omnia ho ma, akurat vpredu.

Po upgrade na TOS6 som pri spusteni v terminali dostaval tiez nasledovnu chybu:

$ rainbow indicator-2 white enable
Warning: Unsupported trigger 'sda' for: system.cfg058bba (rgb:wlan-3)

Riesenim bolo vymazanie odstavca z /etc/config/system:

config led                                       
        option name 'Auto-configuration for PCI3'
        option sysfs 'rgb:wlan-3'                
        option default '0'                       
        option trigger 'sda' 
$ rainbow indicator-2 white enable
$

jak nastavit nizkou intenzitu LED i po rebootu