Po aktualizaci - restartu, se odpojí NTFS NAS


#1

Zdravím, mám připojen NAS s FS NTFS podle postupu na webu, stejně jako kamarád… Ale po aktualizaci novějšího fw se vždy odpojí - v přehledu přípojných bodů stále je, ale v cestě je nově “tmp” a musím ho ručně odpojit a znovu připojit… A následně dát bohužel rescan minidlna… Je nějaké řešení, aby se to nedělo? Nebo je to vlastnost? Děkuji :slight_smile:


#2

V LuCI / Po spuštění zakažte mountd, pak v Systém / Přípojné body dejte ten disk s tmp cestou odpojit a připojte ho ručně jak jste měl dříve.


#3

nechápu reakci… jak jsem psal “a musím ho ručně odpojit a znovu připojit” tak na to jsem prisel jako na reseni toho problemu, kdyz se stane… ale tu se snazim zjistit, jestli existuje reseni, jak se tomuto problemu vyhnout? … - nebo si nejsem jisty , jestli jsem odpoved pochopil…, ale chapu to tak, ze tohle co jste popsal, mi nepomuze v tom, aby se to priste z nestalo co…?


#4

Důležité je to zakázání mountd, které provede připojení nalezených disků samo. Automaticky, do /tmp/mounts/.


#5

OK. to jsem ted udelal, takze mam u mountd “zakázáno”… kdyz jsem predtim ale uz odpojil ten s cestou tmp, a znovu pripojil… tak proste priste kdyz bude aktualizace, restart… tak uz nebudu muset znovu odpojovat tmp, a pripojovat spustenim skriptu nas (podle postupu), ale pojede to porad? :slight_smile: proc to tak vlastne funguje, ze to nebylo rovnou zakazano - nebo spis, co ta sluzba mountd dela, ze je pro mne dulezite ji zakazat? Děkuji


#6

V některé předchozí aktualizaci bylo zavedeno, že se automaticky připojují nově rozpoznané disky, a to zajišťuje mountd,
pokud si je nastavíte ručně (disky), tuto službu zakažte a vaše nastavení by mělo zůstat.
Rychlou kontrolu připojených disků provedete přes konzoli (třeba přes SSH) příkazem mount nebo postačuje df -hT.


#7

Ještě je tady jiné řešení: New USB drive automounts to wrong directory

Vlastně jsem jásal příliš brzy…

Můj první „pokus o řešení“ byl prostě zakázat mountd. Ale to zase přestane fungovat automatické připojování USB zařízení (automount). Což není optimální. Pak jsem našel: https://wiki.openwrt.org/doc/howto/writable_ntfs Kde se doporučuje doplnit do /etc/rc.local správný ntfs-3g příkaz. Takže jsem ho tam přidal s ohledem na moje aktuální připojení „/dev/sdX a /mnt/XXXXX“, restartoval jsem a vše funguje tak jak má. Potom jsem znovu spustil mountd, restartoval a drive je připojený kde ho chci mít a mountd běží. Ještě jsem nezkoušel připojit další usb zařízení…

omlouvám se za strojový překlad


#8

u rc.local bych si nebyl jist, jestli změna přežije hypotetický update… Jenom doplním, že problém se netýká jen NTFS. Mám EXT4 externí disk, a začal se mi taky mountova nadvakrát.


#9

rc.local je označený jako konfigurační soubor a tedy přežije. (viz soubor /usr/lib/opkg/info/base-files.conffiles).


#10

Ok. Moje ext 4YI funguje v NAS dobře. Mám “Time Machine” & SAMBA sdílení.


#11

zvlastni, a nemas ji mountlou 2x? Ja to taky nezjistil (funguje), az jsem se po precteni na foru mrknul a zjistil, ze se mi nove (pri drivejsich restartech to nebylo) mountuje krome definovane cesty taky do /tmp. Matne si vzpominam, jestli jsem uz tohle neresil kdysi. Je mozne, ze se ta sluzba mountd zapla pri updatu, a mozna je to taky neco uplne jineho :slight_smile:

pro uplnost dodam, ze jsem od te doby nerestartoval… zatim jsem jen umountl tempy, checknul Automatic anonymous mount hotplug ve fstabu/mount points (DVB dongle) a zakazal mountd sluzbu.



#12

Ne, nemám. Taky už si to moc nepamatuji, ale postupoval jsem podle návodů na turris.cz pro mount a openwrt pro Time Machine, SAMBA. Vím, že už bylo hodně řečeno… Jen jsem zkoušel propojit 2 vlákna z poslední doby. :wink:


#13

Reseni jsem sepsal zde: New USB drive automounts to wrong directory .