Please explain HBS, HBL & HBD

Hello, it looks to me like I am the only stupid person in this forum to not know what versions (branches) those short names HBS, HBL & HBD are referring too in the posts of the forum. I also didn’t find any blog post explaining it so I’m wondering how everyone get’s to know this but that’s another story.

So it would be very nice if anyone can quickly post an answer what those 3 names are in full writing and what version they stand for if the name is not self explanatory (testing, rc, stable, …)

Thank you very much

It is described in the docs :slight_smile: :


… and in project GitLab too:

I have to admit, I’m not loving the HB* naming convention either. I don’t want to sound miserable but just really miss the more self explanatory: stable, rc, testing naming tradition.

Maybe the Turris team could add ‘sensible’ aliases for me and my fellow boomers ?


At least HBS(table) and HBT(esting) are good to remember :wink:


and as well HBD(angerous). AFAIK: I am not sure if I have something for HBK/HBL.

1 Like

The problem here is that “stable” is actually less stable than rc while testing is in reality just overlay over nightly. It is complicated and original naming convention was rather confusing.

1 Like

:smile: some good points there lol!


At least HBS(table) and HBT(esting) are good to remember