Pinning 6.5.2 repository version instead of 7.0.0

I’m having multiple issues with TurrisOS 7.0.0, which makes it not ready yet for my purposes, hence I’d like to go back to using 6.5.2.

I downloaded the 6.5.2 medkit from https://repo.turris.cz/archive/6.5.2/medkit/mox-medkit-202402150155.tar.gz and flashed it to the sdcard.

I then modified all the lines in /etc/opkg/distfeeds.conf from:

https://repo.turris.cz/hbs/mox/packages/

to

https://repo.turris.cz/archive/6.5.2/mox/packages/

however that affects only opkg. That means that opkg update and opkg install correctly use the archive repository, but turris updater still insists on using the latest 7.0.0 TurrisOS repositories.

There is no current documentation on how to make turris updater use a specific version of the repositories.

I can only find old documentation at Downgrading packages [Turris wiki] but it does not work in TurrisOS 6.5.2 anymore, I tried.

Without documentation, I tried experimenting with editing /etc/updater/conf.d/turris.lua, which unfortunately says at the top This file is part of updater-ng. Don't edit it. and tried changing

local mode = uci_cnf("mode", "branch") -- should we follow branch or version?
local version = uci_cnf("version", nil) -- which version to follow

to

local mode = uci_cnf("mode", "version") -- should we follow branch or version?
local version = uci_cnf("version", "6.5.2") -- which version to follow

but that also did not work. reForis still insists on upgrading to 7.0.0 instead of using 6.5.2 archive as the latest.

What are the correct steps to pin 6.5.2 archive as the latest version of TurrisOS for the updater?

Just use:

switch-branch --version 6.5.2

Or, since you already made a lot of manual modifications, update /etc/config/updater to use mode=version (instead of mode=branch) and set version=6.5.2. E.g.:

diff -Nru @322/etc/config/updater @/etc/config/updater
--- @322/etc/config/updater     2024-02-22 18:47:07.416175234 +0100
+++ @/etc/config/updater        2024-04-25 04:16:29.855731390 +0200
@@ -1,7 +1,8 @@

 config turris 'turris'
-       option mode 'branch'
        option branch 'hbs'
+       option mode 'version'
+       option version '6.5.2'

 config l10n 'l10n'
2 Likes

Thank you, this worked:

switch-branch --force --version 6.5.2

I already made a lot of other changes trying to find the solution without documentation, which broke a lot of things, so instead I did another reinstall and used this switch-branch --version method to pin 6.5.2.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.