Pi-Hole on Turris Omnia?

Does anyone know if it would be possible to install Pi-Hole on the Turris Omnia ?

Pi-Hole is open-source ad-blocking software which installs in Linux. I have it
installed on a Linux server at home and it has transformed my home internet,
but I am looking for an all-in-one router solution so I dont need a separate server.

1 Like

yes, use lxc container with ubintu, and install the pi hole on that ubuntu.
there is some discussion about it somewhere in this forum.



There are IMHO easier ways of blocking ads and trackers, have a look here, http://www.s474n.com/project-turris-blokovani-reklam-a-trackeru/, it’s in Czech but if you know your way around Linux/Omnia a little bit, you could do just with the commands. If not, I’ll happily translate it for you. Works for me like a charm.

It doesn’t work on Omnia (because Omnia doesnt use unbound. It uses knot)

For Omnia you can use this:

1 Like

This works an absolute treat - thanks Nick!

I’ve been running pihole in an ubuntu lxc container for weeks, haven’t had any issues. works great, takes up minimal resources.

Thanks @ubermutant looks perfect.

Some websites, discover that you are blocking ads (in my case when using ublock origin (adblocker) ). How does this work? Do they see that the ads are not being loaded? So the pihole does not work like a adblocker extention?

Pi-Hole acts as a DNS proxy for you. “Blocked” URL domain lookups are simply directed to the Pi-Hole server itself, a “black hole” if you will. The sites have no idea what’s going on because it isn’t something running on your browser itself. Every ad-server you’re trying to look up the IP address for is the address of your Pi-Hole server, which doesn’t serve up ads and simply returns an empty space for your browser to display instead of the ad.

Pi-Hole downloads lists of ad servers from the internet, you can add more (blacklist) or remove some (whitelist). You can also customize where you’re getting your lists from.

If you want a complete ad-blocking solution continue to use an extension like uBlock Origin along with Pi-Hole. But Pi-Hole is a great tool for things like phones, tv devices like Roku and AppleTV, tablets, where it might be harder to install ad-blocking software.

Great community for it on reddit, and their official forums:


There aren’t many websites which still do that because the ones which did ended up losing so many visitors.

I’ve only been using Pi-Hole a couple of weeks, but the only issue I have seen was one article I wanted to
see the link was blocked because I guess it was going to an ad network directly. So I assumed it was clickbait
and didn’t worry about it. You can turn off Pi-Hole in the nice web interface and there are also little tools
which let you disable it on each device.

It works like the ad blocker extension except you dont need to install the extension on all the browsers in the house, plus it works for games and apps on any devices in your network and that also reduces the tracking of your devices because some addresses are for tracking not just ads. My wife complains about using her phone outside the home network because the ads in her games and apps are annoying.

If you have a website which is troublesome for you let me know and I will try it out and tell you how it works.

I had indeed such an idea that it would be doing something like that, which was already what i was planning to install and configure some day. (Youtube ads through Chromecast =_=!).

My only concern is, when you use it as a DNS-proxy, how fast are the DNS servers then? Right now i am using google dns. Or is pi-hole after “filtering-the ads” referring to a custom DNS again?

you point your systems to the pi-hole for dns, preferably through you dhcp server settings, you point the pi-hole to google/opendns/whatever. so really it doesn’t slow you down anything noticable. if you had a system on your network you didn’t want to use the pi-hole, just don’t use it for dns for that box (either override the dhcp settings or set ip configuration up manually).

1 Like

Also, as i assumed, but thanks for the confirmation. Already having a ubuntu LXC doing some work, another addition will be installed soon.

Again thanks for explaining and confirming things.

Hi, I’m trying to get pi-hole up and running, with the help of nickbusey his site. But I’m not so familiar on Unix, so please be gentle.

I have also run into trouble, as Nick mentioned, with the use of the “curl” command. I tried his workaround but ran into some challanges.
Where can I find install.sh or should I make it?
Which commands should come into the file?
Can somebody please give me some pointers (for a just starting guy on Unix) to make the next steps?

Tia Johnnie

Hi Johnnie, others will correct me if I’m wrong but I’m fairly sure that, before the curl command would work I had to type

apt-get install ca-certificates

It should work then I think?

hmm. I can’t remember what I did when I installed mine, maybe curl wasn’t installed by default? if so, type:

apt-get install curl

inside your LXC container to install it. then you should be able to copy and paste their install command without an issue:

curl -sSL https://install.pi-hole.net | bash

be sure that you have set your pi up with a static IP address as well.

hmm. maybe I’ll write up some through documentation on the procedure if someone doesn’t beat me to it.

Best rightsideup and scottjl,

Thanks for the help and you’re both right, I first installed curl and then ca-certificates.

But still have to figure out a thing (maybe more in the future :smile:), when I ran the installation script, you have the possibility to assign a fixed IP-adress, so I did. But after reboot of the lxc, the fixed ip-adress wasn’t working anymore (right after installed it worked)?

Running the script , there was an error message, so maybe there lies the issue?

  • Refresh lists in dnsmasq…/opt/pihole/gravity.sh: line 372: pihole: command not found
    /opt/pihole/gravity.sh: line 409: pihole: command not found
    bash: line 1173: pihole: command not found

I’m now figuring out a way out to get this fixed. What I also saw is that in the pihole interface my fixed ip-adress is advertised, but nothing seems to be living there anymore (no ping response).

Any idea’s?

Again thanks, johnnie

Check found the solution by editing: /etc/network/interfaces

When you set up the LXC container, it doesn’t have a fixed UP address. Unfortunately to do that you’re going to have to muck around on the command line a little on the Omnia. Specifically you need to edit the configuration file and put the IP address in there, probably the easiest way is for you to log into your router and try

vim /srv/lxc/<LXC_CONTAINER_NAME>/config

you want to add the following (under network configuration is good, but it really doesn’t matter where in the file):

lxc.network.ipv4.ipv4 = <static ip address>

Where <static ip address> is a fixed address on your network you want to give it.
It would also be good to add the following:

lxc.network.ipv4.gateway = <router address>

Where <router address> is the address of your default gateway on your network, usually your Omnia’s internal network address.

After this you should reboot your container (or the router), and you’ll have to go in and reconfigure pihole with pihole -r and give it the new static IP address.

1 Like

Hi scottjl,

Thanks again for helping out, I’ve made the changes in /etc/network/interfaces.
Do I have achieved the same?

An other question, on the blog of brian he is mentioning to make an symlink:
" You may need to symlink pihole to the /usr/bin. $ cd /usr/bin; ln -s …/local/bin/pihole pihole"

Wy should I do this and why is it neccesary (btw I’ve read some info in the Inet of symlinks)?

Tia johnnie