Performance problems with LAN port - reduced bandwidth


#1

Hi All,

I have been doing some testing of the performance of the individual ports of the Turris Omnia and found something very troubling. Wanted to ask if somebody has found something similar. Just to eliminate any configuration issues, then I repeated the testing after performing a factory reset of the Omnia router from a USB drive with the latest TurrisOS.

I have a 600Mb/s down and 60Mb/s up Internet connection from Orange in Poland running on an optical fiber.

With the exception of 1 of the LAN ports, when I run speed tests on my Internet network connectivity, I get results as expected … 600Mb/s down and 60Mb/s up within 2-5% of the expected values. However, when I use the LAN2 port, I only get approx 100Mb/s down and 60 Mb/s up.

So, in summary, for all of my LAN ports my upload speed is as expected within a 2-5% tolerance, but my download speed, on LAN2 port is only about 1/6 of all of the other ports. On ports LAN0, LAN1, LAN3 & LAN4 I get 600Mb/s download.

Has anybody encountered something similar? Would anybody have any ideas as to what could be causing such behaviour and how to fix it?

Thanks in advance.


#2

It looks like LAN2 only connects at 100mbit not at gigabit speed.


#3

You are right … but would anybody know as to why? And how to fix it?


#4

This looks like faulty hardware and probably has to be replaced. I don’t know how warranty is handled.


#5

Can you connect to Omnia using SSH and start this command:
swconfig dev switch0 show | grep link


#6

here is the output … I normally use LAN3, but I also plugged it into LAN2 for this command, so there are two iterations … first on LAN3, second on LAN2.

root@turris:~# swconfig dev switch0 show | grep link
link: port:0 link:down
link: port:1 link:down
link: port:2 link:down
link: port:3 link:up speed:1000baseT full-duplex
link: port:4 link:down
link: port:5 link:up speed:1000baseT full-duplex
link: port:6 link:up speed:1000baseT full-duplex
root@turris:~# swconfig dev switch0 show | grep link
link: port:0 link:down
link: port:1 link:down
link: port:2 link:up speed:100baseT full-duplex
link: port:3 link:down
link: port:4 link:down
link: port:5 link:up speed:1000baseT full-duplex
link: port:6 link:up speed:1000baseT full-duplex


#7

Did you use the same Ethernet cable as in LAN3?


#8

Yes, exactly the same cable, same PC, same internet provider, and tests repeated at least twice to make sure I have consistent results.


#9

I am afraid, that in this case it is realy HW problem with Omnia.
You will have to contact support directly at tech.support@turris.cz.


#10

thanks … I’ve sent them an email and will update here once I get a response.


#11

I have tried it on my own, plugging the ethernet cable to LAN2 and it seems to be ok:
link: port:0 link:down
link: port:1 link:down
link: port:2 link:up speed:1000baseT full-duplex
link: port:3 link:down
link: port:4 link:down
link: port:5 link:up speed:1000baseT full-duplex
link: port:6 link:up speed:1000baseT full-duplex


#12

That’s good to hear that it’s working for somebody else … but I’ve reflashed my entire router from the latest image with default settings and my LAN2 nic is still set to 100Mb/s and not 1000Mb/s. I used the instructions as located https://doc.turris.cz/doc/en/howto/omnia_factory_reset.

Does anybody know how to change the settings of individual ports on the router? (I thought that a reflash of the router would definitely fix that type of a problem.)


#13

try to contact Turris team directly in case it is maybe a hardware failure, or if not they can probably help you tracking this down better.


#14

My router is already on it’s way for repairs and/or replacement … can’t wait to get it back.


#15

just wanted to let everybody know that Omnia support came through and delivered a fully functional working router :slight_smile:


#16

Just for the record… You waited 8 months? :open_mouth:


#17

no … it took them about 1 month :slight_smile: … I’ve just came back to these forums after a long break.


#18

Don’t revive old thread(s). :slight_smile:
For warranty cases by a law we have 30 days.