Pakon breaks DHCP on secondary networks

Pakon seems to have caused DHCPv4 serviced by dnsmasq to stop working on my DMZs and guest networks. DHCPv6 still works, just not v4.

This has been a problem both around the release of it, as well as in the current version.

I haven’t checked every network since not all of them have things connected to them at the moment, but I know that LAN works fine while ‘forcevpn2’ does not. Stopping pakon-monitor and restarting dnsmasq doesn’t fix it, only completely uninstalling pakon does.

My /etc/config/network is as follows:


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde9:4e2f:a9a7::/48'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option _orig_ifname 'eth0 eth2 radio0.network1 radio1.network1'
        option _orig_bridge 'true'
        option ifname 'eth0'
        option netmask '255.255.0.0'
        option ip6assign '64'
        list ip6class 'wan6'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        option macaddr 'xxx'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix '64'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0 1 3 4t 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4t 6t'
        option vid '2'

config interface 'dmz'
        option type 'bridge'
        option proto 'static'
        option ifname 'eth2.2'
        option ipaddr '10.2.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        list ip6class 'he'
        option ip6hint '2'

config interface 'bs1tun'
        option proto 'none'
        option ifname 'tun0'
        option delegate '0'

config interface 'forcevpn'
        option proto 'static'
        option ifname 'eth2.3'
        option netmask '255.255.255.0'
        option ipaddr '10.55.0.1'
        option type 'bridge'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '4t 6t'

config route
        option interface 'wan'
        option target '192.168.100.1'
        option netmask '255.255.255.255'

config interface 'he'
        option proto '6in4'
        option peeraddr 'xxx'
        option ip6addr 'xxx'
        option ip6prefix 'xxx'
        option tunnelid 'xxx'
        option username 'xxx'
        option password 'xxx'

config interface 'sep'
        option proto 'static'
        option netmask '255.255.0.0'
        option _orig_ifname 'eth0.4'
        option _orig_bridge 'false'
        option ifname 'eth2.4'
        option ipaddr '10.9.0.1'
        option ip6assign '64'
        option ip6class 'he'
        option ip6hint '9'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option vid '4'
        option ports '4t 6t'

config interface 'dmz2'
        option proto 'static'
        option ifname 'eth2.5'
        option ipaddr '10.11.0.1'
        option netmask '255.255.0.0'
        option ip6assign '64'
        option ip6class 'he'
        option ip6hint '11'

config switch_vlan
        option device 'switch0'
        option vlan '5'
        option vid '5'
        option ports '4t 6t'

config route
        option interface 'bs1tun'
        option target 'xxx'
        option netmask '255.255.255.0'

config interface 'nordvpn'
        option proto 'none'
        option ifname 'tun1'
        option delegate '0'

config interface 'forcevpn2'
        option proto 'static'
        option ifname 'eth2.6'
        option ipaddr '10.56.0.1'
        option netmask '255.255.255.0'
        option type 'bridge'

config switch_vlan
        option device 'switch0'
        option vlan '6'
        option vid '6'
        option ports '2 4t 6t'

config interface 'iotstuff'
        option type 'bridge'
        option proto 'static'
        option ifname 'eth2.7'
        option ipaddr '10.88.0.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option ip6hint '88'
        option ip6class 'he'

config switch_vlan
        option device 'switch0'
        option vlan '7'
        option vid '7'
        option ports '4t 6t'

config switch_vlan
        option device 'switch0'
        option vlan '8'
        option vid '8'