OS 5.0, luci switch module missing?

hi, we upgraded Omnia ver CZ11NIC13 to OS 5.0

in luci is missing switch configuration, is it a bug ?

thank you

As far as I can tell no. The omnia was/is one of the first devices that where started with the DSA switch architecture instead of the OpenWrt’s old swconfig approach. (The upstream Linux kernel network maintainers had decided against swconfig and for DSA, so it was clear that DSA was “the way”). Now, DSA and swconfig are not compatible and until recently there simply was no way to parse the switch configuration from UCI and apply it to DSA switches. I believe there is now upstream work in OpenWrt that will allow LUCI/GUI configuration of DSA switches, but that is pretty much work in progress (so not done yet and also not guaranteed to reach completion, but I think it will work out, as OpenWrt seems inclined to switch to DSA as well*)

*) The reason for that switch is that DSA support can be upstreamed to the main line linux kernel, while swconfig is something OpenWrt needs to carry and maintain as independent patches that require more care and maintenance than upstreamed components would.

thank you, please tell me, where can i look for switch configuration from shell

i am not able to found the right configuration files

thank you !!

Well, DSA is different, the idea is to treat switch ports much more like ethernet interfaces in linux and allow the standard tools to manipulate them. tools like ip and friends.
Personally, I have no first hand experience* in configuring the omnia’s DSA switch (or any DSA switch for that matter) so i will refrain from posting my guesses. There should be some users on this list much more versed in that issue.

*) I am a simple mind, if I can avoid VLAN trickery, by say running extra dedicated cables I tend to do so :wink:

There are a lot of forum posts about this but none of them really make it simple/clear on what to do.

  1. They have not built any direct configuration support for DSA into the product yet, both in UI or configuration files.
  2. It sounds like they intend for any such support to be made through openwrt’s codebase instead of coding it in themselves. It looks as if this is being worked on for openwrt, but I don’t see any releases yet.

Here is what I do for my config, which is I’ll admit, a bit odd.

I send all of my traffic from my Omnia (which is upstairs where i get the best wireless signal across the house) over one cable to a managed switch that is downstairs with the rest of my equipment, modem included.

I tag the traffic for LAN to VLAN1, the traffic for the modem to VLAN2, and the traffic for my guest wireless to VLAN3.

All 3 of them pass over one cable from the switch upstairs to the Omnia, and goes into port 3.

This required two methods if configuration to work properly

In the interfaces section of the UI (or the /etc/config/network file)

  1. make the interface for LAN traffic ‘lan3.1’ which tags it as VLAN1
  2. make the interface for WAN traffic ‘lan3.2’ which tags it as VLAN2
  3. make the interface for DMZ traffic ‘lan3.3’ which tags it as VLAN3

By itself this worked for wireless clients, but the LAN ports no longer worked, so I had to also do the following below

  1. set PVID to 1, and tag all packets that go out of lan3.1 and br-lan

    bridge v a dev lan3.1 vid 1 tagged
    bridge v a dev br-lan vid 1 tagged self

  2. set PVID to 3 and tag all packets that go out on lan3.3 and br-dmz

    bridge v a dev lan3.3 vid 3 tagged
    bridge v a dev br-dmz vid 3 tagged self

  3. remove VLAN settings that existed before I made my changes, as they are no longer valid

    bridge v d dev br-dmz vid 1 self
    bridge v d dev lan3.3 vid 1

After that, everything worked, LAN ports included. Depending what you are doing, you may not need to descend into bridge commands. If you do, make sure you put them in /etc/rc.local so they apply on boot. (but PLEASE test this before you do, so you don’t lock yourself out)

My understanding of this is limited it its possible I am doing more than I should, or less than I should, in my bridge commands. Feedback is welcome and if I can get a better understanding I can post a wiki article about this stuff so others can find it too.

This is what my bridge v output looked like after the changes

# bridge v
port	vlan ids
lan0	1 PVID Egress Untagged
lan1	1 PVID Egress Untagged
lan2	1 PVID Egress Untagged
br-dmz	3
lan3.3	3
br-lan	1
lan3.1	1
wlan1	1 PVID Egress Untagged
wlan0	1 PVID Egress Untagged
wlan1-1	1 PVID Egress Untagged
wlan0-1	1 PVID Egress Untagged
wlan0-2	1 PVID Egress Untagged