Optimization of Throughput

Hi everybody,
I have a Turris Omnia Router and i want to improve the Throughput. For the measurement i use Iperf.
My problem is i change many time the parameter for a better througput but i have only max. 96 Mbits/s. I need help and i will be glad if someone have a tips for me.

Thank you

What is your iperf test-bed?

  • router instance connecting to upstream WAN instance?
  • router instance connecting over wire to LAN client instance?
  • router instance connecting over the air to Wlan client instance?
  • router client instance connecting/routed over wire/air to router to upstream WAN instance?

what is the expectation?

My Iperf test-bed is : router instance connecting to LAN Raspberry Pi. My server is my PC and the Client is Raspberry Pi. I expect 900Mbits/s throughput.

  • 1 iperf instance on PC -> connecting to TO over wire/air?
  • 1 iperf instance on RPi -> connecting to TO over wire/air?


Two things come to my mind:

  1. Which version of RPi do you have because just last 4B has real GE interface
  2. Did you check negotiated speeds on both connections (if wired) as it seems that it’s only 100M somewhere (bad cable/connector) ?

PC is over air ( WLAN) and my Raspberry Pi is connected to Router over Ethernet cabel.
On my PC and Raspberry i habe Iperf3 Software. The PC is server and the Raspberry is Client.

I have Raspberry Pi 2 Model B.

I don’t know how far exactly one can get with Omnia’s default card(s), but 900 Mbps doesn’t sound realistic for real-life Wi-Fi.

1 Like

What can be realistic?

It depends on the frequency band (2.4 GHz or 5 GHz) and the Wlan environment/landscape (angles, distances, interferences, channel saturation etc).

So this is your bottleneck, Raspberry Pi 2 Model B only has Fast Ethernet, so 96 MBit/s is expected.

Even though 900 MBit/s via WiFi is still unrealistic as @vcunat wrote…

1 Like

Ok can i run iperf on the Router? then my Router can be the Server and my PC and Raspberry Client?
if yes how can i run it on my Router?

iperf3 package is part of the base installation. Try from the TO cli iperf3 -h