OpenWrt 21.02 RC1 is in HBD branch

@Twinkie and @Pepe
Turris 1.x tested, will not start. transition used via switch-branch.

Listing from the console:

U-Boot 2015.04-04654-gbcfb33e-dirty (Jun 26 2015 - 12:50:49)

CPU0:  P2020E, Version: 2.1, (0x80ea0021)
Core:  e500, Version: 5.1, (0x80211051)
Clock Configuration:
   CPU0:1200 MHz, CPU1:1200 MHz,
   CCB:600  MHz,
   DDR:400  MHz (800 MT/s data rate) (Asynchronous), LBC:37.500 MHz
L1:    D-cache 32 KiB enabled
   I-cache 32 KiB enabled
wdt status 00000005 reset
   Watchdog enabled
Board: TURRIS CPLD: V4.1 PCBA: V4.0
Error, wrong i2c adapter 2 max 2 possible
in: 56
out: 0
io_config: 255
rom_loc: nor upper bank
SD/MMC : 4-bit Mode
eSPI : Enabled
I2C:   Error, wrong i2c adapter 2 max 2 possible
ready
SPI:   ready
DRAM:  Error, wrong i2c adapter 2 max 2 possible
Detected UDIMM 9905594-003.A00G
WARNING: Calling __hwconfig without a buffer and before environment is ready
WARNING: Calling __hwconfig without a buffer and before environment is ready
2 GiB (DDR3, 64-bit, CL=6, ECC off)
Flash: 16 MiB
L2:    512 KiB enabled
NAND:  256 MiB
MMC:   FSL_SDHC: 0
PCIe1: Root Complex of mini PCIe SLOT, no link, regs @ 0xffe0a000
PCIe1: Bus 00 - 00
PCIe2: Root Complex of PCIe SLOT, x1 gen1, regs @ 0xffe09000
  02:00.0     - 168c:0030 - Network controller
PCIe2: Bus 01 - 02
PCIe3: Root Complex of PCIe SLOT, x1 gen1, regs @ 0xffe08000
  04:00.0     - 104c:8241 - Serial bus controller
PCIe3: Bus 03 - 04
Error, wrong i2c adapter 2 max 2 possible
In:    serial
Out:   serial
Err:   serial
Net:   Phy 5 not found
PHY reset timed out
eTSEC1
Error: eTSEC1 address not set.
, eTSEC2
Error: eTSEC2 address not set.
, eTSEC3 [PRIME]
Error: eTSEC3 address not set.

Hit any key to stop autoboot:  0
BOOT NAND
reading zImage
5300517 bytes read in 257 ms (19.7 MiB/s)
wdt status 00000003
reading fdt
12147 bytes read in 15 ms (790 KiB/s)
WARNING: adjusting available memory to 30000000
## Booting kernel from Legacy Image at 02100000 ...
   Image Name:   Linux-5.4.150
   Created:      2021-10-02  23:15:25 UTC
   Image Type:   PowerPC Linux Kernel Image (gzip compressed)
   Data Size:    5300453 Bytes = 5.1 MiB
   Load Address: 00b00000
   Entry Point:  00b0029c
   Verifying Checksum ... OK
## Flattened Device Tree blob at 02000000
   Booting using the fdt blob at 0x2000000
   Uncompressing Kernel Image ... OK
   Loading Device Tree to 03ff9000, end 03ffef72 ... OK
WARNING: could not find compatible node fsl-usb2-dr

This issue, which you described on Turris 1.x routers, prevents us from pushing the HBD branch into the HBL branch.

There is created an issue in our GitLab:

1 Like

Hmm issue create two months ago. What is the plan to resolve it ? Are we going to wait for Linus Torvalds to resolve it ? There are probably not much people with knowledge to debug linux kernel. Or are we going to wait for openwrt community to come up with new kernel version or kernel patches?

1 Like

We have in house kernel developers that are assigned to it and are capable of tackling the issue. It is just not the only issue they have to work on and till we move 5.3 out of the HBL branch it is also not a pressing one.

2 Likes

Offtopic: Lions Lions Lions !!!

1 Like

A package for fail2ban has been merged into 21.02: https://github.com/openwrt/packages/pull/16592 . Will it automatically become available in Turris OS or do I need to raise an issue on the issue tracker for it being built?

1 Like

Everything that is included in the stable branch, we have it unless it does not compile for some reason (usually ~10 packages). There is no way to backport the patches from the same branch, which is the specific Turris OS version that uses.

This is somehow different than you are used to from Turris OS 3.x, when we forked the repository and maintained ourselves. These days, we have just patches (turris-build repository) and our feed (turris-os-packages repository) with just our packages.

You can see that fail2ban is present already in HBD. For reference:
https://repo.turris.cz/hbd/omnia/packages/packages/fail2ban_0.11.2-3.9-1_arm_cortex-a9_vfpv3-d16.ipk

This link can be changed in the future as the package can be updated (different versioning), but it is good to take a look to our repo.

1 Like

Great, thanks! Maybe you could think about integrating fail2ban into reforis to allow users further hardening of their routers? But it is probably not that hot taking into account the high level of security Turris products offer.

Question for those using it by now - is Wi-Fi stable for daily use? I’d really like to get back the switch functionality NOW (having to use an external switch costs 10Wh extra around the clock!) but don’t want to sacrifice Wi-Fi stability (women acceptance factor = close to zero, only complete internet drop outs are rated worse) …

I am on HBD 21.02 on 2 omnia routers, used wifi permanently, no issues.

The OpenWRT 21.02 base is released as stable now… I know there are a few Turris specifics that might be troublesome, but the basics should be OK. I plan to move soon to 21.02 too…

1 Like

Thanks alot!
One last question: did the change from HBS to HBD work without issues or should I revert settings to standard bevor switching branches? Especially the syntax-change in network-UCI would brake everything. The current 5.2.x config

config interface 'lan'
	option ifname 'lan0 lan1 lan2 lan3 eth2.1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config interface 'guest'
	option ifname 'eth2.2'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'

should be according to the Mini tutorial for DSA network config - Network and Wireless Configuration - OpenWrt Forum transformed for TO v.6 HBD into

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'eth2'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'eth2:t*'

config bridge-vlan
	option device 'br-lan'
	option vlan '2'
	list ports 'eth2:t'

config interface 'lan'
	option device 'br-lan.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config interface 'guest'
	option device 'br-lan.2'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'

So is there a script in place that converts the current config into something working? Without that network would become unreachable - or did I get something wrong?

1 Like

It is backward compatible. Your network will be reachable. You don’t need to make any changes manually in the configuration files. You can proceed with the migration script in LuCI (Network tab). Be aware that the new configuration is not currently supported in reForis, so it means no WAN/LAN tab (AFAIK).

1 Like

After switch to HBD and TOS 6, i was a bit confused, as everything stopped working on wifi. But solution was to connect via cable, go in LUCI to interfaces and it created message to “migrate” and it migrated configuration. Then it worked, but took me a while to realize it. Switch on my second omnia was already OK then, as i knew what to do.

So switch to 6.0 worked (especially the network script part :slight_smile: ) but it seems my wifi won’t come up.
Which kernel modules and packages do I need to have installed for the WLE900VX to work? I installed the following packages:

The cards are recognized correctly...
root@TO:~# lspci
00:01.0 PCI bridge: Marvell Technology Group Ltd. 88F6820 [Armada 385] ARM SoC (rev 04)
00:02.0 PCI bridge: Marvell Technology Group Ltd. 88F6820 [Armada 385] ARM SoC (rev 04)
00:03.0 PCI bridge: Marvell Technology Group Ltd. 88F6820 [Armada 385] ARM SoC (rev 04)
01:00.0 Network controller: Qualcomm Atheros QCA986x/988x 802.11ac Wireless Network Adapter
02:00.0 Network controller: Qualcomm Atheros QCA9984 802.11ac Wave 2 Wireless Network Adapter
03:00.0 Network controller: Qualcomm Atheros QCA9984 802.11ac Wave 2 Wireless Network Adapter
...as well as initialized...
Oct 27 17:34:40 TO kernel: [    9.533235] ath10k 5.10 driver, optimized for CT firmware, probing pci device: 0x3c.
Oct 27 17:34:40 TO kernel: [    9.541286] pci 0000:00:01.0: enabling device (0140 -> 0142)
Oct 27 17:34:40 TO kernel: [    9.547171] ath10k_pci 0000:01:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
Oct 27 17:34:40 TO kernel: [    9.814314] ath10k_pci 0000:01:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
Oct 27 17:34:40 TO kernel: [    9.823596] ath10k_pci 0000:01:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
Oct 27 17:34:40 TO kernel: [    9.832975] ath10k_pci 0000:01:00.0: firmware ver 10.1-ct-8x-__fH-022-ecad3248 api 2 features wmi-10.x,mfp,txstatus-noack,wmi-10.x-CT,ratemask-CT,txrate-CT,get-temp-CT,tx-rc-CT,cust-stats-CT,retry-gt2-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT crc32 1b2a161c
Oct 27 17:34:40 TO kernel: [    9.886933] ath10k_pci 0000:01:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
Oct 27 17:34:40 TO kernel: [   10.744355] ath10k_pci 0000:01:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
Oct 27 17:34:40 TO kernel: [   10.761325] ath10k_pci 0000:01:00.0: wmi print 'P 128 V 8 T 410'
Oct 27 17:34:40 TO kernel: [   10.767375] ath10k_pci 0000:01:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
Oct 27 17:34:40 TO kernel: [   10.775404] ath10k_pci 0000:01:00.0: wmi print 'alloc rem: 25000 iram: 38944'
Oct 27 17:34:40 TO kernel: [   10.841511] ath10k_pci 0000:01:00.0: htt-ver 2.2 wmi-op 2 htt-op 2 cal otp max-sta 128 raw 0 hwcrypto 1
Oct 27 17:34:40 TO kernel: [   10.851247] ath10k_pci 0000:01:00.0: NOTE:  Firmware DBGLOG output disabled in debug_mask: 0x10000000
Oct 27 17:34:40 TO kernel: [   10.963059] ath: EEPROM regdomain sanitized
Oct 27 17:34:40 TO kernel: [   10.963063] ath: EEPROM regdomain: 0x64
Oct 27 17:34:40 TO kernel: [   10.963065] ath: EEPROM indicates we should expect a direct regpair map
Oct 27 17:34:40 TO kernel: [   10.963071] ath: Country alpha2 being used: 00
Oct 27 17:34:40 TO kernel: [   10.963072] ath: Regpair used: 0x64
Oct 27 17:34:40 TO kernel: [   10.964637] ath10k 5.10 driver, optimized for CT firmware, probing pci device: 0x46.
Oct 27 17:34:40 TO kernel: [   10.972753] pci 0000:00:02.0: enabling device (0140 -> 0142)
Oct 27 17:34:40 TO kernel: [   10.978710] ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
Oct 27 17:34:40 TO kernel: [   11.177278] ath10k_pci 0000:02:00.0: qca9984/qca9994 hw1.0 target 0x01000000 chip_id 0x00000000 sub 168c:cafe
Oct 27 17:34:40 TO kernel: [   11.187250] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
Oct 27 17:34:40 TO kernel: [   11.198965] ath10k_pci 0000:02:00.0: firmware ver 10.4b-ct-9984-fH-13-5ae337bb1 api 5 features mfp,peer-flow-ctrl,txstatus-noack,wmi-10.x-CT,ratemask-CT,regdump-CT,txrate-CT,flush-all-CT,pingpong-CT,ch-regs-CT,nop-CT,htt-mgt-CT,set-special-CT,tx-rc-CT,cust-stats-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT,wmi-bcn-rc-CT crc32 2da3d868
Oct 27 17:34:40 TO kernel: [   12.495957] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id 0:1 crc32 85498734
Oct 27 17:34:40 TO kernel: [   14.970148] ath10k_pci 0000:02:00.0: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
Oct 27 17:34:40 TO kernel: [   14.977683] ath10k_pci 0000:02:00.0: msdu-desc: 2500  skid: 32
Oct 27 17:34:40 TO kernel: [   15.057133] ath10k_pci 0000:02:00.0: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
Oct 27 17:34:40 TO kernel: [   15.068053] ath10k_pci 0000:02:00.0: wmi print 'free: 84936 iram: 13428 sram: 11224'
Oct 27 17:34:40 TO kernel: [   15.348849] ath10k_pci 0000:02:00.0: htt-ver 2.2 wmi-op 6 htt-op 4 cal otp max-sta 32 raw 0 hwcrypto 1
Oct 27 17:34:40 TO kernel: [   15.443076] ath: EEPROM regdomain sanitized
Oct 27 17:34:40 TO kernel: [   15.443080] ath: EEPROM regdomain: 0x64
Oct 27 17:34:40 TO kernel: [   15.443082] ath: EEPROM indicates we should expect a direct regpair map
Oct 27 17:34:40 TO kernel: [   15.443088] ath: Country alpha2 being used: 00
Oct 27 17:34:40 TO kernel: [   15.443089] ath: Regpair used: 0x64
Oct 27 17:34:40 TO kernel: [   15.445277] ath10k 5.10 driver, optimized for CT firmware, probing pci device: 0x46.
Oct 27 17:34:40 TO kernel: [   15.453366] pci 0000:00:03.0: enabling device (0140 -> 0142)
Oct 27 17:34:40 TO kernel: [   15.459331] ath10k_pci 0000:03:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
Oct 27 17:34:40 TO kernel: [   15.647868] ath10k_pci 0000:03:00.0: qca9984/qca9994 hw1.0 target 0x01000000 chip_id 0x00000000 sub 168c:cafe
Oct 27 17:34:40 TO kernel: [   15.657835] ath10k_pci 0000:03:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
Oct 27 17:34:40 TO kernel: [   15.669602] ath10k_pci 0000:03:00.0: firmware ver 10.4b-ct-9984-fH-13-5ae337bb1 api 5 features mfp,peer-flow-ctrl,txstatus-noack,wmi-10.x-CT,ratemask-CT,regdump-CT,txrate-CT,flush-all-CT,pingpong-CT,ch-regs-CT,nop-CT,htt-mgt-CT,set-special-CT,tx-rc-CT,cust-stats-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT,wmi-bcn-rc-CT crc32 2da3d868
Oct 27 17:34:40 TO kernel: [   16.970581] ath10k_pci 0000:03:00.0: board_file api 2 bmi_id 0:31 crc32 85498734
Oct 27 17:34:40 TO kernel: [   19.455463] ath10k_pci 0000:03:00.0: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
Oct 27 17:34:40 TO kernel: [   19.463002] ath10k_pci 0000:03:00.0: msdu-desc: 2500  skid: 32
Oct 27 17:34:40 TO kernel: [   19.542402] ath10k_pci 0000:03:00.0: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
Oct 27 17:34:40 TO kernel: [   19.553322] ath10k_pci 0000:03:00.0: wmi print 'free: 84936 iram: 13428 sram: 11224'
Oct 27 17:34:40 TO kernel: [   19.833541] ath10k_pci 0000:03:00.0: htt-ver 2.2 wmi-op 6 htt-op 4 cal otp max-sta 32 raw 0 hwcrypto 1
Oct 27 17:34:40 TO kernel: [   19.923066] ath: EEPROM regdomain sanitized
Oct 27 17:34:40 TO kernel: [   19.923069] ath: EEPROM regdomain: 0x64
Oct 27 17:34:40 TO kernel: [   19.923071] ath: EEPROM indicates we should expect a direct regpair map
Oct 27 17:34:40 TO kernel: [   19.923077] ath: Country alpha2 being used: 00
Oct 27 17:34:40 TO kernel: [   19.923078] ath: Regpair used: 0x64

…but the only information syslog gives me is

Oct 27 15:50:24 TO netifd: radio0 (5984): Command failed: Request timed out
Oct 27 15:50:24 TO netifd: radio0 (5984): Command failed: Not found
Oct 27 15:50:24 TO netifd: radio0 (5984): Device setup failed: HOSTAPD_START_FAILED
Oct 27 15:54:51 TO netifd: radio0 (10418): Command failed: Request timed out
Oct 27 15:54:51 TO netifd: radio0 (10418): Command failed: Not found
Oct 27 15:54:51 TO netifd: radio0 (10418): Device setup failed: HOSTAPD_START_FAILED
Oct 27 15:55:00 TO netifd: radio1 (10733): Command failed: Request timed out
Oct 27 15:55:00 TO netifd: radio1 (10733): Command failed: Not found
Oct 27 15:55:00 TO netifd: radio1 (10733): Device setup failed: HOSTAPD_START_FAILED

Any idea how to solve this?

This one should solve it.

/etc/init.d/wpad enable
/etc/init.d/wpad start

Thanks alot - I read this somewhere but obviously forgot about it. Sry :frowning:
Now the cards are up and running… :clap:
… but only in 80 MHz mode. When choosing 160MHz the DFS-scann fails (for channel 36 as well as for channel 100):

Oct 27 18:33:12 turris hostapd: wlan1: interface state UNINITIALIZED->COUNTRY_UPDATE
Oct 27 18:33:12 turris hostapd: wlan1: interface state COUNTRY_UPDATE->HT_SCAN
Oct 27 18:33:12 turris hostapd: wlan1: interface state HT_SCAN->DFS
Oct 27 18:33:12 turris hostapd: wlan1: DFS-CAC-START freq=5500 chan=100 sec_chan=1, width=2, seg0=114, seg1=0, cac_time=60s
Oct 27 18:33:12 turris hostapd: DFS start_dfs_cac() failed, -1
Oct 27 18:33:12 turris hostapd: Interface initialization failed
Oct 27 18:33:12 turris hostapd: wlan1: interface state DFS->DISABLED
Oct 27 18:33:12 turris hostapd: wlan1: AP-DISABLED 

Any idea?

I haven’t tried wireless card 80+80 MHz or 160 MHz on the HBD branch yet. Sorry.

I should be able to look at it perhaps next week.

2 Likes

Ok, so both of the WLE1216v5-20 cards work fine (when choosing 80MHz-channels), but the 2,4GHz-network is nowhere near stable. I own the indiegogo-variant where the WLE900VX-card disappears after warm reboots. The card never disappeared while being used - until now. This evening it disappeared out of a sudden two times in one hour - everytime when I tried to change tx-power via luci. Interestingly both times the webUI froze for some seconds before I got thrown out and had to re-login in luci - seems like this is some webUI-isue. To solve this the TO needs to be powered off for more than 30 seconds, the card won’t reappear when it is up and running.
I will test it for another day and hopefully this was just bad luck today - if it continues I need to revert to 5.x.

But it seems to me that with OpenWrt 21.02 in general is not that stable when it comes to WIFI - my WRT32x is completely unusable (yet my WRT1900AC and WDR3600 are running for weeks without any problem by now).

edit: I had to rollback to 5.x due to constantly unusable WIFI on a SGS 8 (android v.8.1) - ping is extremely high (~700ms) and instead of ~60MBit/s I only get 1,5MBit/s. So WAF: :-1: :poop:
I will try again in the near future - maybe with pure ath10k (none-ct-variant), but for now WIFI needs to be stable for some time. Otherwise I will get crucified at my antennas…

Hi,
i am starting to have an issues on HBD TOS 6. I am not sure, what causes the problem, but i have 2 main symptoms:

  • if i copy data from laptop (conencted via cable or wifi doesn’t matter), copy from laptop to NAS (NAS connected via cable), speed is equal. But vice versa, if i copy from NAS back to laptop, speed is around 8Mb/s (around 1MB/s) only. I dont have explanation for that, i tried different laptop, same result. I tried to connect directly laptop - NAS and speeds are equal in both directions
  • second thing i realized is, i have wireguard tunnel between 2 turris HBD TOS 6 - here replication is runing to offsite location to second NAS. So far so good, but if replica is bigger and should run on full load, again speed is around 1MB/s only and at time of bigger replica replication during this time my local network is almost dead, i have almost no internet (optical 350/40 Mb/s), pages are ending with error, i have no DNS responses in cmd. Looks like it just overloads, even there is no reason for that.