OpenVPN stopped working

One year ago, I installed OpenVPN on my Turris Omnia via opkg (Foris integration was not available at this time). Worked flawlessly until today.
No all I get is:

Mon Mar 12 18:26:36 2018 MANAGEMENT: >STATE:1520875596,WAIT,,,,,,
Mon Mar 12 18:27:36 2018 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon Mar 12 18:27:36 2018 TLS Error: TLS handshake failed
Mon Mar 12 18:27:36 2018 SIGUSR1[soft,tls-error] received, process restarting
Mon Mar 12 18:27:36 2018 MANAGEMENT: >STATE:1520875656,RECONNECTING,tls-error,,,,,

I didn’t change anything. All I know is, that there have been udpate to Omnia last week (and I didn’t use OpenVPN since then).

While trying to find any reason, I removed OpenVPN completely and installed it again via Foris. Did a configuration with the Foris plugin. Still, the same problem.

Any idea what’s going on here?

Thanks a lot!


how are you trying to connect? Via Android phone? I had the same problem with the officiial andoid client. It is not working with that, but it works with OpenVPN for Android, which is also suggested to be used by documentations.

On Android and Windows with the official OpenVPN clients. Never had any problems with both of them.

After a lot of trial and error I realised, that I had a wrong firewall rule. Forget to add a remote port. So everything was routed to the wrong internal port.

Same issue here. The firewall rule was automatically created. Anything that needs to be adjusted here?

I had the same issue yesterday. I searched for updates in reForris and updated. It works now. But reForris and LuCi does not :slight_smile: