OpenVPN server does not work

I had high hopes with the Turris Omnia that it would allow even not so tech savvy users to use OpenWRT easily and safely. Unfortunately this has not been the case so far.

I set up OpenVPN via FORIS and now I want to set it up on the client Android phone. I have donwloaded the config file. Once I rename the file to OVPN (as stated inside the file) it can import, but no connection can be made. The app always states “There was an error attempting to connect to the selected server”. I had to enter the IP manually inside the downloaded CONF file. Autodetection did not seem to work as in the file it is stated “remote <server_adddress> 1194”. I tried both the IPv4 and IPv6 address according to “”.

When trying to connect via OpenVPN-GUI on my Windows 10 PC, he cannot resolve the IPv4 address but with the IPv6 at least I get “read UDPv6: Unknown error (code=10054)”. The Turris Omnia is connected to the internet via a Unitymedia router, but on this one I disabled the firewall, so it should not be a blocked port.

This is now the second time I’m trying to get OpenVPN going. One time via SSH when there was not the “quick and easy” setup via Foris and now via Foris. Both times it did not work.

Could it be an issue of the provider? I use the cable provider Unitymedia.

Is there a way I can find out if the configuration is done correctly and it is a client issue?

Is the OpenVPN process up and running? I had issues that after the installation the process was not started, although it was properly configured using FORIS. You can check the processes using the LUCI web interface.

It was running (at least that’s what I gather from the process below). Then I restarted the process, tried again and it didn’t work. Then I restarted the router and now the process is not running.I had to re-apply the configuration in Foris to restart it.

Yes! Unitymedia gives you a DSlight Connection by default, which means that you have no public ipv4 adress by default. To get a public ipv4 adress you need to buy a so called „PowerUpload“ Option for 3€ per month. After that you can ask Unitymedia support to change your connection to real DualStack.

Just google for yourself, there is much information about this topic (mostly in german language) in Unitymedia forums. :slight_smile:

Edit: Do you have a white „ConnectBox“ from Unitymedia? If yes then you can set it to Bridge-Mode after you switched to real DualStack, which turns it into a real modem (so no routing happens there any longer).

Damnit. Had some issues with Netflix before so I was kinda suspecting that. I do have the white connect box.

Thank you very much!

Okay, well then at least you know what you can do now :slight_smile:

There was (is?) a bug in OpenWRT so that your Omnia behind your ConnectBox in Bridge Mode still uses DSlight while real DualStack is available. To fix it you have to add the following line in /etc/config/network in section „wan6“:

option iface_dslite '0'

Just keep this in mind if you decide to change your setup as I described above.

Good luck

1 Like