OpenVPN not working after router reboot


each time my Omnia Turris gets rebooted, OpenVPN stops working. Meaning, I can not connect. Restarting the OpenVPN-service via /etc/init.d/openvpn restart helps. But that can only be done if I’m at home ;).
As actually the service is broken again, I can’t provide you with any logfiles. But do you have any ideas, how I could try to solve this as soon as I get near the router?


Quickfix idea:

crontab -e
@reboot sleep 120 && /etc/init.d/openvpn restart

But this doesn’t solve the real issue of course

1 Like

Nice one :slight_smile:
But you’re right, doesn’t solve the issue. Will try to get some logs in the evening.

try the command:

/etc/init.d/openvpn enable && /etc/init.d/openvpn start

You were completely right. The service wasn’t enabled. Which is mysterious, because I used Foris to set it up.
Thanks a lot!

1 Like