OpenVPN client not generated


i have found out, in OpenVPN section creation of new client configuration file stopped working. On both my turris omnia. VPN works OK and already generated client files as well, but i cant create new one.

Is it bug? Or what to check?



I’m experiencing similar issues.

I can not generate new config files for new clients, but I was unsure whether it is actually not working, or they simply do not appear in the list presented by Forris as it exceeded 8 “slots”.

FYI: I have tried to create a key on my turris, which has not yet generated 8 keys in total, and I see no issue creating them (using webbased foris/config method). That seems to strengthen the hypothesis that it might just be a UI issue, rather than an actual issue of generating the keys :slight_smile:

I have this problem on my Turris 1.1

we’re not aware of this issue.

We tried to generate it with 9 and 10 clients. We have no issues and we can create more.

Guys do you have the latest version of Turris OS, which is 3.9.5?
Did you restart your router?

Hi, i tried on my device at home, after restart it started working. I dont remember , if i restarted after last update 3.9.5 or not.

Thanks for hint. Will try on second in the office as well, but probably same reason.


DOH! I can confirm that rebooting solved it for me (sorry for the confusion @Pepe). :blush:

(Normally the Omnia reboots automatically after a time-out (grace) period, but apparently it didn’t this time.)

Is there a way to find (and possibly delete) the configuration files by means of the CLI too (not using the Foris web-GUI which is asked in another topic already)?

I have a similar issue. TurrisOS 3.10 on rtrs02. After generation of the CA when trying to add a client, it says “Generating” forever. The certificate is generated but the UI does not reflect it. There was no previous client configuration available.

Rebooting does not help. Reinstall does not help.

I faced similar issue after upgrade to 3.10.

The solution was provided here:

Sorry that I hijack this thread but I’m not allowed to open a thread.

My Turris is stuck at generating CA for weeks now. Also the new OS Version did not fix it.
Can someone help me please?

Turris OS version 3.10.1
Kernel version 4.4.134-8f7f4132dc88fb7034ce9648e5961be5-0