Omnia Switching Vlans and interfaces


#1

Hi

I really dont understand switching on this device, my old TPlink with openwrt have only one physical interface eth0, in default router have 2 vlans with ID 1 and 2. Vlan 1 is for virtual interface eth0.1 and vlan 2 is for interface eth0.2.
eth0.1 is part of LAN zone and eth0.2 is part of WAN zone. So switch configuration was: in vlan 1 port0-3 is untagged,
port4 is off and cpu tagged. In vlan 2 port0-3 is off, port4 is untagged and cpu tagged.

When i need new network i just create new vlan 3 with interface eth0.3 and then zone, for example guest_lan and join eth0.3 under guest_lan (and new firewall rule of course).

But on Omnia i really dont understand switching.
For me it looks like this:

Router has 3 physical interfaces eth0 [RGMII0] (for lan zone and ports 0-3) eth1 [SGMII2] (for wan zone and wan/sfp port) eth2 [RGMII1] (for lan zone port 4). So CPU has 3 IO with capability 3Gbit/s full duplex

but vlan configuration looks strange: vlan 1 ports 0-3 untagged all other ports off and cpu untagged
vlan 2 ports 4 and WAN untagged all other ports and cpu off.

Can you draw something like this ? https://wiki.openwrt.org/_detail/media/tplink/tl-wr1043/tl-wr1043nd-v2_schematics.png?id=toh%3Atp-link%3Atl-wr1043nd

And would be nice have wiki, like openwrt or add your device to openwrt wiki :slight_smile:

Odpoved moze byt kludne aj cesky :slight_smile: dakujem
Sorry for my english


Help set up IPTV
#2

Something like this?
Disclaimer:
I give no warranty on any number in this image. Only for decoration purposes.
eth-numbers are taken from the post above. Connections are from the schematic.

UPDATE: eth0 is connected to the switch port 5 and eth2 is connected to the switch port 6.


Ports schematic Turris Omnia
Another Dumb Question About VLAN's
VOIP and IPTV VLANs on separate physical ports
Ethernet interface speed/duplex manual settings?
Firewall stop / LAN zone removal cuts access to the router
#3

If I understood it correctly the WAN ports/zone are not using any VLANs at all by default?
It’s possible to create VLAN(s) on them? Or add some of physical ports (LAN4) to WAN zone (for example as someone here already asked for IPTV so he can plug STB to LAN4 and it would be like some “dumb” switch between ISP and Turris? (I apologize if I’m out of topic)


#4

Yep, depending what do you want to achieve. You can create eth1.1, eth1.5, … in networks if your WAN is VLAN trunk. You can also switch eth0 or eth2 to tagged mode on switch and create eth1.2 and put it into the bridge with WAN port.

You can simply bridge those.


#5

Thanks for explanation. I hope that it answered also OP question and that my Omnia would arrive soon (black 2GB :frowning: :smiley: )


#6

Ok but why switch configuration looks like this:

Why eth2 and eth1 must be part of eth0.2 vlan ? Or luci interface is wrong ?
I expecting something like this :

Thanks for help


#7

By default all CPU ports are untagged. There is no VLAN on WAN. Actually from Linux point of view there are by default no VLANs at all. There are VLANs set on switch chip in a way that resembles your third picture. Except, as WASN is connected directly to CPU, there is no VLAN on it.


#8

yes that is true, lan is on eth0 and eth2 and wan is on eth1. But for what he need that vlans eth0.1 and eth0.2 …When i remove this vlans ports not working (link is up but no connection).


#9

Sorry I don’t understand. If you want to have two separate VLANs on eth0, you need to setup switch so the port would be tagged on switch tab in LuCI. Then you would get both VLANs and you can separate them in OpenWRT. But I think by default VLANs with ids 1 and 2 are used in switch to differentiate between traffic for eth0 and eth2, so it would make sense to choose different IDs or reconfigure everything.


#10

Ach !! sorry :slight_smile: my mistake, now i understand … thanks for help


#11

Hm, yesterday I was fighting with the vlan setup in luci for quite a long time with just partial success.
It doesn’t seem to be straight forwad to understand how to configure the switch. Maybe some “examples” or some documentation (Did I overlook some?) might be helpul.

I tried to set up additional vlan (untagged) for DMZ. Without much success.
To the default config I added vlans 3 and added port 1 to this vlan. Then I created new Interface “DMZ”, set up IPv4 addres, and DHCP and assigned the new eth0.3 to this interface. I as well removed the eth0 from LAN and added just eth0.1 and ath0.2.
According the configuration in luci everything seems as expected (same as on one of my older routers), but I can’t ping the turris from the port assigned to DMZ.
Obviously I misunderstood something. :frowning:

In the end I attached the DMZ on the port next to WAN port and added the eth2 to DMZ interface instead. But I need one more vlan and no matter what I can’t figure out how to set it up.


#12

Did you set in switch chip port for eth0 as Tagged?


#13

in luci you can create vlnas only under eth0. So

If you need more ports in your dmz zone try this configuration for switch:
from default configuration state.

  1. create new vlan (ID 3)
  2. add ports for your device as untagged
  3. add port CPU as tagged (under vlan 3)
  4. add eth0.3 under dmz interface
  5. add eth0.1 under lan interface or leave under eth0 (i think if you set eth0.1 then set CPU port tagged under vlan 1)

Configure from port 4

This work for me


#14

I did more or less all as you write, except I did not add the CPU port as tagged to all the VLANs. That might be the catch.
I’ll give it a try once I get home.


#15

Hi all, I recently received my omnia and I am very happy with it, but the switch configuration was very confusing, since I was used to a more straightforward configuration of a switch with a single cpu interface (on the tp-link wdr4300). So, after many hours of trial and error here’s what I figured out, please correct me if I didn’t get things right:

As stated and shown in the diagram in a previous post, the CPU used in the omnia provides 3x1gbit network interfaces, named eth0, eth1 and eth2. The switch connects to the CPU with two interfaces, Port 5 -> eth0 and Port 6 -> eth2 (eth1 is the WAN interface and is separate from the switch). In the default configuration, there are no VLANS in use (all ports are untagged). What you see in LuCI as CPU port (Port 5) is the eth0 device, and Port 6 is eth2. So at first you have ports 0-3 of the switch connected to eth0 and port 4 connected to eth2.

The eth0.1 and eth0.2 devices you might see while configuring your router are actually unusable at this point. eth0.1 cannot be used because tagging is not enabled in eth0. The existence of eth0.2 is plain confusing since the vlan with the id 2 is assigned to the eth2 interface so there should be a eth2.2 device and NOT eth0.2.

Now, if you want to enable VLAN tagging and create more VLANs for eth0, go to switch config, make Port 5 (“CPU” in LuCI) tagged for VLAN id 1 and BEFORE applying the settings make sure to set the ‘lan’ interface to include eth0.1 in the bridge and not eth0 that is the default, otherwise you will lose access to the router if you are connected to it via ethernet. After that you can add VLANs and use them in other interfaces etc.

If you want to use VLANs with eth2 you’ll have to set Port 6 as tagged for those VLANs and manually create the corresponding devices (e.g. eth2.3 for VLAN id 3). You can do that if you go to “Physical Settings” of an interface in LuCI and select “Custom Interface”.


#16

Then… I can not have the same tagged VLAN in eth0 and eth2, true?

For example, this is not valid:

config interface 'lan’
option ifname ‘eth0.2 eth2.2’
[…]

config interface 'dmz’
option ifname ‘eth0.3 eth2.3’
[…]

config switch_vlan
option device 'switch0’
option vlan '2’
option ports ‘0 1 2 3 5t 4 6t’

config switch_vlan
option device 'switch0’
option vlan '3’
option ports ‘0t 1t 2t 3t 5t 4t 6t’

And this neither:

config interface 'lan’
option ifname ‘eth0.2 eth2.2’
[…]

config interface 'dmz’
option ifname ‘eth0.3 eth2.3’
[…]

config switch_vlan
option device 'switch0’
option vlan '2’
option ports ‘0 1 2 3 5t’

config switch_vlan
option device 'switch0’
option vlan '2’
option ports ‘4 6t’

config switch_vlan
option device 'switch0’
option vlan '3’
option ports ‘0t 1t 2t 3t 5t’

config switch_vlan
option device 'switch0’
option vlan '3’
option ports ‘4t 6t’


#17

Hello,

  • What’s the difference between eth0 and eth2? IMHO both have the same physical connection.

  • Through which interfaces are the WiFi cards connected?

  • Why has port 4 a different VLAN configuration in the default switch configuration than the ports 0-3?

  • Where can a find the “CPU” port? Is port 5 connected to eth2 the “CPU” port?

I try to verify the layout with the TP-Link TL-WR1043ND schematics.

CU Jörg


#18

The most helpful post to me was the one a bit above your post: https://forum.turris.cz/t/omnia-switching-vlans-and-interfaces/1089/15

The only thing I do not understand/know is what Port 4 in the switch config refers to.


#19

Hello Jan,

just to resume:

  • The interfaces eth0 and eth2 are equal.

  • The default VLAN configuration is “banana:wink:.

  • CPU ports are port 5 and port 6.

Did you find out through which interfaces the WiFi cards are connected?

CU Jörg


#20

Not quite, in switch config:

  • Ports 0-3 are eth0 (are labeled LAN0-3 on the case)
  • Port 4 might be the WAN Port, which would be eth1, unclear to me
  • Port 5 is the CPU
  • Port 6 is eth2 (is labeled LAN4 on the case)
  • WiFi cards are radio0 and radio1 bridged to eth0 and eth2 in the default config
  • Yes, default VLAN config is confusing :slight_smile: