[Omnia 4G] Out-of-the-box setup failure

Brand-new Omnia 4G box does not succeed, making a link via its Quectel LTE-module.

I’ve tried with several different SIM-cards, following the instruction on Turris Docs.
I’ve combined these with various resets and reinstalls via the reset-button on the back of the device. Including a full OTA from Turris’ repository.
The installed OS is v7.0.0 everytime.
Modem gets detected, ModemManager gets installed and - fiddling with the logs - I’m able to see things akin to this:

May 29 06:52:50 turris netifd: Interface ‘gsm’ is setting up now
May 29 06:52:50 turris netifd: gsm (12983): modem available at /org/freedesktop/ModemManager1/Modem/0
May 29 06:52:50 turris netifd: gsm (12983): starting connection with apn ‘NoTellNoOne’…
May 29 06:52:50 turris [6328]: [modem0] simple connect started…
May 29 06:52:50 turris [6328]: [modem0] simple connect state (4/8): wait to get fully enabled
May 29 06:52:50 turris [6328]: [modem0] simple connect state (5/8): register
May 29 06:53:53 turris netifd: gsm (12983): error: couldn’t connect the modem: ‘GDBus.Error:org.freedesktop.ModemManager1.Error.MobileEquipment.NetworkTimeout: Network timeout’
May 29 06:53:53 turris netifd: gsm (13161): stopping network
May 29 06:53:53 turris netifd: gsm (13161): couldn’t load bearer path
May 29 06:53:53 turris netifd: Interface ‘gsm’ is now down

Executing “mmcli -m 0” on a ssh-loginshell gets me this, showing that the modem is indeed present:

root@turris:~# mmcli -m 0
  General  |                    path: /org/freedesktop/ModemManager1/Modem/0
           |               device id: 653d09d80aa325a60410b8bcc8ae4d6f24aaxxxx
  Hardware |            manufacturer: Quectel
           |                   model: EP06-E
           |       firmware revision: EP06ELAR03A08M4G
           |          carrier config: ROW_Generic_3GPP
           | carrier config revision: 06010821
           |            h/w revision: 20000
           |               supported: gsm-umts, lte
           |                 current: gsm-umts, lte
           |            equipment id: 868186041241xxx
  System   |                  device: /sys/devices/platform/soc/soc:internal-regs/f1058000.usb/usb1/1-1
           |                 drivers: qmi_wwan, option1
           |                  plugin: quectel
           |            primary port: cdc-wdm0
           |                   ports: cdc-wdm0 (qmi), ttyUSB0 (qcdm), ttyUSB1 (gps),
           |                          ttyUSB2 (at), ttyUSB3 (at), wwan0 (net)
  Status   |                    lock: sim-pin2
           |          unlock retries: sim-pin (3), sim-puk (10), sim-pin2 (3), sim-puk2 (10)
           |                   state: enabled
           |             power state: on
           |          signal quality: 68% (cached)
  Modes    |               supported: allowed: 3g; preferred: none
           |                          allowed: 4g; preferred: none
           |                          allowed: 3g, 4g; preferred: 4g
           |                          allowed: 3g, 4g; preferred: 3g
           |                 current: allowed: 2g, 3g, 4g; preferred: 4g
  Bands    |               supported: utran-1, utran-3, utran-5, utran-8, eutran-1, eutran-3,
           |                          eutran-5, eutran-7, eutran-8, eutran-20, eutran-28, eutran-32,
           |                          eutran-38, eutran-40, eutran-41
           |                 current: utran-1, utran-3, utran-5, utran-8, eutran-1, eutran-3,
           |                          eutran-5, eutran-7, eutran-8, eutran-20, eutran-28, eutran-32,
           |                          eutran-38, eutran-40, eutran-41
  IP       |               supported: ipv4, ipv6, ipv4v6
  3GPP     |                    imei: 86818604124xxxx
           |           enabled locks: fixed-dialing
           |             operator id: 23820
           |            registration: idle
  3GPP EPS |    ue mode of operation: csps-2
           |  initial bearer ip type: ipv4v6
  SIM      |        primary sim path: /org/freedesktop/ModemManager1/SIM/0

I’ve sent an email to Turris support last week - still no answer, not even an email stating my query has been received.

From the logs I see that there’s a network timeout, triggering failure. Right. The SIM in use in this case is a standard M2M card with known APN and no PIN. It works just fine in the device it was borrowed from. Other SIMs were borrowed from standard cellphones - same result.
The SIMs are put in place with padding to avoid this issue:

Also, I see that other people are having similar problems:

Retracing steps from above issue gets me a similar result:

root@turris:~# mmcli -m 0 --3gpp-scan
  3GPP scan | networks: 23801 - TDC (lte, available)
            |           23802 - TelenoDK (lte, available)
            |           23806 - 3 DK (lte, available)
            |           23820 - Telia (lte, current)
root@turris:~# mmcli -m 0 --3gpp-register-home
error: couldn't register the modem: 'Timeout was reached'

Can someone on here point me in a direction? Where do I go next?

I’d try setting a 1234 PIN.

@peci1: Retry using PIN 1234 - just to trigger something:


which is a perfect repetion of the attempt without any PIN. Fail.

Note: Log is GMT, local timezone is Copenhagen/GMT+2, which accounts for the 2hr difference. I think.

And did you actually set the PIN on the SIM?

Here is a document for nearly all settings from Telia DK. Perhaps you will find out something for you that helps you out to make it going. (PDF)

General Terms and Conditions for Telia Danmark’s Communication Services (Enterprise)

  • What SIM must be having PIN entered and what not
  • What APN name must be entered and so on

Perhaps the same issue I finally solved by switching antenna connectors - for further explanation look at this post. Check it and if you have also connected antenna to the middle one on your Quectel card use only both on the sides and remain middle one disconnected.


In the middle is the GPS antenna connector, for the Quectel EP06 and
a active antenna with 3 or 5 meters cable and magnetic “foot” will be a
really good options. So you get GPS time on top of all and being able
to set up your own Stratum0 / Stratum1 NTP server for your network.

@mino Well, this must be the lowest-possible-tech genius solution I’ve seen in years.
The connector was misplaced. At the factory!
This was BOUGHT as a ready-to-run 4G solution provider, and little did I think to go over the antenna connections, what with a perceived 68% signal strength and all.

Moved connector, restarted interface, BANG! Online.

Now, I get an IP and link works. I’m writing this post via 4G…
Oddly, ReForis sees the device as ‘unavailable’. Reason unknown.

Time to put the device back in the hands of the owner and let him fit his own SIM card etc.

Thanks a million for this unbelievably simple solution.

@ Turris support/manufacturing personnel: Feel free to go hang your heads. I’ve had no warnings, no advice or even an answer to mails. Silence.

1 Like

@Sparky thanks a bundle, but the SIM being used is an M2M thing we have for our products. And I’m part of the team writing embedded code using the datachannel offered by said SIM. We have admin-access to the SIMs.

Still, asking the community for help is indeed very effective. Often, seeing things from a different perspective offers up some amazing solutions.

Thanks for chipping in :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.