Nslookup fails on some sites

Hi Guys,

Hoping I can get some direction on how to troubleshoot this. I only noticed the problem when I tried to connect a device to my network (smartoil sensor) and it kept failing. I looked in the logs and saw that nslookup keeps failing. I went into Luci and tried diagnostics, and get inconsistent results. The default openwrt.org returns “;; connection timed out; no servers could be reached”, whereas for google.com, I get:

Name: google.com
Address 1:
Address 2:
Address 3:
Address 4:
Address 5:
Address 6:
Address 7: 2607:f8b0:4004:c1d::8a
Address 8: 2607:f8b0:4004:c1d::64
Address 9: 2607:f8b0:4004:c1d::65
Address 10: 2607:f8b0:4004:c1d::66`

That seems like the normal response (I’m a noob.) I tried changing DNS providers in reForis, and the weird thing is that when I changed to quad9 (unfiltered), I’d get results for openwrt.org–but when I restarted the Omnia, it doesn’t work any more.

I’m worried that I’ve borked the dns settings somewhere in the Omnia, can someone help me figure this out?