Non-bridge LAN and Turris not responding


#1

Hello,

I would like to disable the bridge with the LAN port (port 0, interface eth0) as I don’t have utility for this. But, each time I do it I cannot connect to the router anymore. Do I have to do perform some other settings if I disable the bridge for the LAN ?


#2

My take is you only connect to the TO via WLAN and there is no connectivity once the eth0 is removed fron the LAN iface?
Are you running the LAN solely on IPv6?
Are the clients still able to connect to the internet and only the TO is not accessible or there is no connectivity at all?
Did you reboot the TO after having removed eth0 from the LAN iface?

It seems a bit inexplicable but then the network management package netifd is outdated and buggy in TOS3.x and this could be just another peculiar consequence.

You could try via ssh edit etc/config/network, there is no option for it in LuCI/Foris:

option type 'bridge'
option bridge_empty '1'

If that does not help this additional step might do the trick:

Install kmod-dummy and add dummy0 as ifname


#3

Hi n8v8r,

The only thing I did was :

  1. Connect on LuCI interface
  2. Network -> Interface -> LAN -> Physical settings -> untick “Bridge interfaces” -> select “VLAN…eth0.1”
  3. reboot
  4. No Internet, no access to TO

Then I have to reset the router (2 LEDs) or sometimes factory reset the router (3 LEDs).

I’m not using IPV6 and I didn’t do the settings with /etc/config/network but I guess when I de-select “Bridge interfaces” this is what happens.

I will check for the kmod-dummy and dummy0 ifname.


#4

The WLAN adapter needs to be bridged in order to work.


#5

The WLAN adapter needs to be bridged in order to work.

You mean LAN ? Because my WLAN has never been bridged.


#6

Problem solved. CPU need to be tagged (Also for other VLANs).

Thx