No serial communication possible


i can’t communicate with a serial usb adapter with turris mox. i use a [DSD TECH SH-U06A USB to TTL] Adapter. i have connected as in: Serial connection - Turris Documentation

Do I need to configure anything to communicate with the serial connection?

Do you run Linux? If so, does issuing stty -F /dev/ttyUSB0 -crtscts in terminal before opening the serial port make any change?

yes, i run linux. ubuntu 22.04 to be exact
good question, i have not tried it. what makes stty -crtscts ? i try it next time

baudrate 115200 is okay?

how I open best the serial connection? i use putty, hterm and minicom

It disables the hardware flow control of the serial interface.

are the stty settings ever used?

I don’t understand your question.

when i set settings with stty, are the settings used with putty, hterm and minicom or have their own terminal settings?

It depends on the program you use. Some might reset the serial port parameters, I think minicom works this way.

In one terminal open the minicom with minicom -D /dev/ttyUSB0 -b 115200 and in the second terminal type the stty command in the earlier post.