No link on MOX C


I’ve received my Turris MOX a few days ago and I have a hard time starting it up.
At first, I’ve only had two rapid blinks at boot. I’ve flashed the sdcard myself with this procedure and now it’s seems ok

But still, the MOX C (ethernet) does not show any link when plugging in a network cable. I’m not event sure if it’s a hardware related issue or a software one.


For software i can recommend “Reset Mode 6” if you have a way to connect your MOX to an existing Internet connection
(the button pressing is a bit tricky to change the mode you have to press it when the led is 3 seconds on to change to the next mode).

For Hardware if you have more than one module check if they are in correct order .

When powering my MOX on the lights on my E-Modul (8xEthernet) light up for a short time in order of port number, i guess C-Modul should do the same thing but this is just a guess, i don’t know for sure.

Thanks, I suppose it should be the same. So I’m really looking toward an hardwaire failure here. I’ll have a quick look

About “reset mode 6”, I don’t know if it’s worth the try as I already download the last version of software and put it myself on the SD card

So I’ve tried both Reset Mod 4 and 6, and also I disconnected other modules from A. I’m still no able to have a ping or a webpage.

The Modul A gets an IP from my local router