No IP-address on WAN port


#1

I’ve been having this problem since I got the Turris Omnia in around April '17, but I haven’t really bothered to look into it until now.

In short, my problem is that if I connect the Omnia directly to the Internet, it doesn’t get an IP-address, but if I connect it through a different router it works.

My internet connection consists of a RJ45-jack straight from the wall. The DLINK is my old router.

The following setups all works:

  1. Computer --> Omnia --> DLINK --> Internet
  2. Computer --> DLINK --> Internet
  3. Computer --> Internet

The following doesn’t:
4. Computer --> Omnia --> Internet

All of the devices have different MAC-addresses, and if I switch from setup 2 to setup 3, for example, it takes just a few seconds for the Computer to get an IP-address from my ISP. So it doesn’t seem to be a problem with different MAC-addresses.

If I use setup 4, the WAN interface (eth1) on the Omnia doesn’t get an IP-address. Here is the output of the command (on the Omnia)

# udhcpc -i eth1
udhcpc: started, v1.25.1
udhcpc: sending discover
udhcpc: sending discover
udhcpc: sending discover**

If I run the same command in setup 1, the result is

udhcpc: started, v1.25.1
udhcpc: sending discover
udhcpc: sending select for 192.168.0.194
udhcpc: lease of 192.168.0.194 obtained, lease time 86400
udhcpc: ifconfig eth1 192.168.0.194 netmask 255.255.255.0 broadcast 192.168.0.255
udhcpc: setting default routers: 192.168.0.1

The fact that setup 1, 2 and 3 works indicates that the problem is not with the ISP, but with the Omnia.

I’ve tried to switch the Omnias MAC-address with the one of the DLINK router, and with the computer, but I get the same result. I’ve also tried to install dhcpcd, but that had the same problem.

Does anyone have any idea on how to fix this?


#2

This a (a/v)dsl line, right?

The TO does not provide a (a/v)dsl modem, hence scenario 1 & 2 work due to the dlink modem. For scenario 3 there is problaly a software modem emulated in the computer, or the computer features a hardware modem.


#3

It’s not a xDSL-line, it a fiber optics line which is converted into a RJ45 (regular Ethernet connection) that goes into my apartment. The D-link is a D-Link DIR-655, which doesn’t seems to be modem, since according to this site: https://eu.dlink.com/no/nb/support/faq/routers/wireless-routers/dir-series/dir-655/how-do-i-setup-and-install-my-dir-655

you would need to connect it to a DSL-modem if you have a DSL-line, and in my case the Dlink is connected into the ethnernet jack in my apartment.


#4

Ok, that setup was not so clear from the initial post.

It might be a simple cable (wiring) issue. I recall that in the past with some eth cable type I would not get an IP from a router (not particuarly the TO though) and then with another cable type it worked.

Not sure whether the TO is sensitive about Cat5, Cat5e, Cat6, Cat6a.


#5

I havent tried with different cables, that could be worth looking into. I’m using the same cable between the Turris and Internet as i use between the Turris and the DLINK, but maybe there is something with the cable.