No acces to Turris! ssh keys changed, HACKED?

Problems with my routher:

Hi all i’ve been on the road for the past 3 weeks, but since I got back my routher is acting very strange! Before I left I was facing storage issues on my turris omnia. My virtual machines often lead to a full disk. usually i checked “schapps list” and delete a few of the old backups. To make some space for my virtual machines, all fine so far…

When I got back i noticed that i couldn’t reach the routhers configuration page in my browser. Furthermore, all my virtual machines where down…
i tried to log in using ssh but I was told that the i could not login with my key. somehow the authentication key on the turris omnia changed…
Finally I was able to log in using “-o PreferredAuthentications=password” and started looking around.

Exactly no disk space free, removed the content of /tmp/ and tried to delete one of the two snapshots that where left, but i looked like it failed…

rebooted, nothing… power cycled, nothing… tried to reset, nothing, tried to rollback to previous snapshot, nothing…

This brings me to some questions:
Did the turris update itself to 3.8, resulting in using more disk space and therefore block itself?
Did the upgrade result in changing the keys?
What would you propose to get my routher back up?



Furthermore I have tried to rollback to the latest medkit and tried to reset to factory settings. However both didn’t seem to work…

At this point I am completely locked out from my routher. I don’t see the wifi, cable doesn’t work (i don’t get an ip adress)

How should i proceed to gradually get back into my routher?

This most likely is a problem with recent updates. Try factory reset, button + 3 LEDs from the left.

Hi Kixorz. I tried that multiple times. However i don’t get get my routher back to work after a factory reset. (no ip adresses are distributed, no wifi signal).
Is it possible that some files need to be written to the storage in order to perform a factory reset? And therefore, due to my full storage, it aborts the reset procedure?
Furthermore it looks like my factory reset happens very quick, another indication for an abort of the factory reset…
Video of the reset in this link

Looking forward to hear your experience!


John, I unfortunately don’t have enough insight into the restoration system to be able to help you. My guess is that full storage shouldn’t prevent factory reset. Keep trying. If it doesn’t work, enter mode 4 and restore from USB drive from the front port.

okay thanks! i’ll try again.