Nextcloud does not install in MOX

Hi all. Nextcloud refuses to install for me. I am using the Nextcloud package, and Nextcloud-install.

Using both the GUI and command line results in a failure to install.

Any ideas?
ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/tmp/mysql_nextcloud.sock’ (2 “No such file or directory”)
Creating nextcloud database failed

Hi @brm,
It might be related to recent update (4.10) which broke installation of mysql server (mariadb). Should be fixed in next release or simply install the mariadb packages from turris repo (you would need to grep them from hbk branch: mariadb-client and mariadb-server).

Hi, thanks for your reply. I have been following others in an attempt to find a solution.
My log shows ‘/var/run/mysqld/mysqld.sock’ (2 “No such file or directory”)

  • But no sign of this file on my system.

find / -type s

I have installed mariadb-client and mariadb-server present in LuCI software but cannot get past the Nextcloud web interface at I can put in some details of database user and password - connect to localhost etc. Unfortunately no luck yet.

I will keep trying a few things that google may bring up, and wait for the update to (4.10)

Looking at packages in LuCI, I see see “mariadb-server-extra” and “mariadb-client-extra”

Any thoughts on these?


Thanks for reporting to us. This issue should be solved very soon. Currently, the fix is in RC (Testing branch). If you are interested in, you can switch to Testing branch by following command in SSH:

switch-branch hbt

Then probably you will need to reinstall Nextcloud package. You can do it in Updater tab, where you need to uncheck it, press the Save & Apply button, wait for a while, check it and again save it.

Should be fixed since yesterday. Can you please let us know, if it was solved for you?

Hi, I get the following error appearing in Notifications. Thus I am not sure if Nextcloud is reinstalled.

Error from 2019/09/25 20:33:41

Updater failed:

compilation: [string “file:////etc/updater/conf.d/auto.lua”]:4: ‘=’ expected near ‘’

May I ask you if you would be so kind to share the content of file /etc/updater/conf.d/auto.lua? I’ve checked and since Turris OS 4.0 you shouldn’t have it and thus it leads me to the theory that you created the file with some content, which is not right.

Does this look right ?

more /etc/updater/conf.d/auto.lua
Install(“nextcloud-install”) pkgupdate

That trailing pkgupdate is wrong. Remove it and it should be fine.

Also you need to have it in that file only once.