New OpenWrt 18.06 - are builded images (SNAPSHOT)

New OpenWrt 18.06 - are builded images (SNAPSHOT) for Turris Omnia:


Am I correct that the omnia images will not work on Turris 1.x (blue box) hardware?

Turris 1.x and Turris Omnia have the different processor architecture (PowerPC vs. ARM)


Thank you for clearing that up. I have one of each now, but just got the Omnia last week.

@DarioX7 Darek did you try this snapshot already? I am considering giving a try.

It’s unclear to me how to install the -sysupgrade.img.gz from the snapshot. sysupgrade won’t do it from a stock ROM… I imagine I could dd it from the initramfs… is that the right answer or is there something easier?

@turris-admin team could we ge some hardware guy to lookover/ack the work?

1 Like;a=commit;h=9f3f61a0d968fbe7b93899f948f3c34612683ba6

2 install methods available.

1 Like

It’s unclear how exactly that works in the new 18.06rc1 and rc2 releases. The method 1 with medKit don’t work for me, I followed exactly all steps, but the flashing process didn’t start, end up with the same System I already have running (TurrisOS 3.10.3). Tried alle Formats FAT/EXT/BTRFS, renamed the files accordingly, …

Method 2 I cannot try atm, because lack of TTL Cable.

Anyone got it running with medkit?

Also, is it possible in OpenWRT to use the Quectel EC20 LTE Modem, which was included in LTE Pack?

I recommend to make new thread about this to Lede/OpenWRT forum.

I was able to flash with medkit from openwrt page.
I do have a TTL cable, so I was able to watch things go.
You need to put the images on the USB key in EXT4 format.
I have since sysupgraded’ed to the release 18.06.

Found the problem, the root= was wrong,

env default -a

solved the problem, and I’m back to Turris. Maybe the LED-4 operation should do that too…?

A post was merged into an existing topic: Building Turris OS