New interface created and Tx stay at 0

Hello,

I created a new interface through LuCi but I don’t receive any DHCP reply from the router. In network -> Interface settings I can see that Tx is 0:

Protocol: Static address
Uptime: 0h 3m 48s
MAC: D8:58:D7:xx:xx:xx
RX: 16.52 KB (49 Pkts.)
TX: 0 B (0 Pkts.)
IPv4: x.x.x.x/24

My /etc/config/network for this new interface look like this:

config interface 'switch'
        option device 'lan1'
        option proto 'static'
        option ipaddr 'xx.xx.xx.xx'
        option netmask '255.255.255.0'

And for /etc/config/dhcp:

config dhcp 'switch'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'switch'
        list dhcp_option '6,xx.xx.xx.xx'
        option force '1'
        list ra_flags 'none'

FYI:

root@router:~# cat /etc/turris-version
6.3.3

Any idea about how to fix this ?

Did you create a firewall zone for this interface or attach it to an existing one?

Yes I have a firewall zone for this interface. Below my /etc/config/firewall:


config defaults
        option forward 'REJECT'
        option synflood_protect '1'
        option input 'REJECT'
        option output 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option family 'ipv4'
        list network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        list network 'wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config include
        option path '/usr/share/firewall/turris'
        option reload '1'

config include
        option path '/etc/firewall.d/with_reload/firewall.include.sh'
        option reload '1'

config include
        option path '/etc/firewall.d/without_reload/firewall.include.sh'
        option reload '0'

config rule
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule 'turris_wan_6in4_rule'
        option enabled '0'

config include 'bcp38'
        option type 'script'
        option path '/usr/lib/bcp38/run.sh'
        option family 'IPv4'
        option reload '1'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'any'
        option reload '1'

config zone
        option name 'wifi2'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option family 'ipv4'
        option forward 'REJECT'
        list network 'wifi2'

config zone
        option name 'wifi5'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option family 'ipv4'
        option forward 'REJECT'
        list network 'wifi5'

config forwarding
        option dest 'wan'
        option src 'wifi2'

config forwarding
        option dest 'wan'
        option src 'wifi5'

config zone
        option name 'switch'
        option input 'REJECT'
        option forward 'REJECT'
        option output 'REJECT'
        list network 'switch'

config forwarding
        option dest 'wan'
        option src 'switch'

Problem solved. By copy/pasta the firewall rule, I noticed the ‘REJECT’ for the interface.

Thanks

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.