Network wide ad blocking with LED indicator

I did a write up on how to set this up, I thought some of you may be interested.


Thanks, I might get into that later.

We always think about blocking ads but wouldn’t you agree that the opposite effect –to click on everything– might be even more confusing for those click-loving-companies?

I came across this project (Ad Nauseam) that does just that, it literally clicks on everything on the page so instead of being ruled out because you don’t click, you’re now included but you’re data can’t be used to establish your ad profile.

The most amusing part is that it has a chrome extension! :joy:

That sounds good if your goal is just to ‘confuse click-loving-companies’. I run ad blockers to keep my network fast, to avoid malicious scripts, and to better control what gets executed on my machines. So something like Ad Nauseam, while entertaining, would have the opposite effect of what I’m going for.

Found an error:

You may need to symlink pihole to the /usr/bin. $ cd /usr/bin; ln -s ../local/pihole pihole

should be

You may need to symlink pihole to the /usr/bin. $ cd /usr/bin; ln -s ../local/bin/pihole pihole

there is /bin missing

Works great, thanks!

1 Like

I’ve updated the post, thanks!

Great post thank you.

I was able to get the curl or wget command to work after I updated/installed the the curl or wget package in the PIHOLE container. After attaching to your pihole container I ran these commands.

  1. apt-get update
  2. apt-get upgrade
  3. apt-get install curl
  4. apt-get install wget
  5. apt-get install nano (this is optional but makes it easy fixing files using the command line)
  6. curl -L | bash
  7. or you can use this command wget -O
    if you use wget you need to also do chmod +x To run the installer use this command: ./

Thanks for your great work on this.

1 Like

Thanks for the recipe, Nick. Between you and John Irvin, I had little trouble installing into a Jessie container. I did find a gotcha though. Depending on when rainbow starts up, your script may be interfered with. In LuCI >System>Rainbow, scroll down to Color and Status of User 1 and click add, change color to custom FF00FF and change status to off.

I also modified your recipe after noticing that the Jessie container can write to the lights, so I put your script in /root/ within the container and changed the line

tail -f /srv/lxc/pi-hole/rootfs/var/log/pihole.log | while read INPUT

to read

tail -f /var/log/pihole.log | while read INPUT

I start it by editing /etc/rc.local (again, within the container) and adding the line

/root/ &

before exit 0.

I hope this is helpful.

1 Like

Hi, the link is not working anymore, wanted to revisit it since the adblocking stopped working after latest turris update.
I guess the dns need to be pointing to the pihole again or something. Dont really remember the setup now, thats why I wanted to review the setup steps.

I am that I wrote down the important parts while that site was still up. I find that after certain updates I need to do the following to get pihole working again.

  • edit the /etc/config/dhcp file and change “option port” from “0” to “53”

Yes, that was the information I was looking for. Thank you so much!

Hi Nick, I’m afraid that the link for your setup is down (HTTP 404 Not Found).
Could you please update the URL?

It would be even better if the contents were moved to a page at the community documentation wiki on the Turris site, located here:


There is a Czech howto and reportedly it’s usable via google translator.

1 Like