Need Debian Jessie in available LXC containers

Trying to install pi-hole, and it fails if I use Debian Stretch or Buster. Jessie was the last distro that worked. Can it be restored to the list for the available repositories, or how can I download it manually?

I was facing the same issue and solved it by using a LXC container with the most recent version of Ubuntu.

Thanks, which specific version of Ubuntu did you go with? I am having trouble with Ubuntu as well, so I am not sure if the issue is with the new (4.1) version of pi-hole. I cannot get the pi-hole installer script to finish. It either drops back to a command prompt with no errors, or it calls out an error on a specific line of the script.

I went for Xenial. But the version of PiHole I used was 4.0. The problem might be related to version of PiHole as you are suggesting.

Is there an option to forcibly install version 4.0?

Based on your requests, we’ll consider to add back Debian Jessie.

We have added it back, it will appear for you in a few hours as it is independent of releasing a new version of Turris OS.

Just ran this:

root@turris:~# lxc-create -t download -n pi-hole

Setting up the GPG keyring

Downloading the image index




Turris_OS stable armv7l default 2018-12-12

Turris_OS stable ppc default 2018-12-12

Alpine 3.7 armv7l default 2018-12-12

Alpine 3.7 aarch64 default 2018-12-12

Alpine 3.8 armv7l default 2018-12-12

Alpine 3.8 aarch64 default 2018-12-12

Alpine Edge armv7l default 2018-12-12

Alpine Edge aarch64 default 2018-12-12

ArchLinux latest armv7l default 2018-12-12

ArchLinux latest aarch64 default 2018-12-12

Debian Stretch armv7l default 2018-12-12

Debian Stretch aarch64 default 2018-12-12

Debian Buster armv7l default 2018-12-12

Debian Buster aarch64 default 2018-12-12

Gentoo stable armv7l default 2018-12-12

openSUSE 42.3 armv7l default 2018-12-12

openSUSE 15.0 armv7l default 2018-12-12

openSUSE 15.0 aarch64 default 2018-12-12

openSUSE Tumbleweed armv7l default 2018-12-12

openSUSE Tumbleweed aarch64 default 2018-12-12

Sabayon 16 armv7l default 2018-12-12

Ubuntu Xenial armv7l default 2018-12-12

Ubuntu Bionic armv7l default 2018-12-12

Ubuntu Cosmic armv7l default 2018-12-12

Ubuntu Cosmic aarch64 default 2018-12-12


Distribution: Debian

Release: Jessie

Architecture: armv7l

Downloading the image index

ERROR: Couldn't find a matching image.

lxc-create: lxccontainer.c: create_run_template: 1201 container creation template for pi-hole failed

lxc-create: lxc_create.c: main: 274 Error creating container pi-hole


You can not install the Distribution and it’s release, if it’s not listed.

You can install Debian Jessie since 16:30. See, my output from lxc-create:

root@turris:~# lxc-create -t download -n jessie
Setting up the GPG keyring
Downloading the image index

Turris_OS	stable	armv7l	default	2018-12-13
Turris_OS	stable	ppc	default	2018-12-13
Alpine	3.7	armv7l	default	2018-12-13
Alpine	3.7	aarch64	default	2018-12-13
Alpine	3.8	armv7l	default	2018-12-13
Alpine	3.8	aarch64	default	2018-12-13
Alpine	Edge	armv7l	default	2018-12-13
Alpine	Edge	aarch64	default	2018-12-13
ArchLinux	latest	armv7l	default	2018-12-13
ArchLinux	latest	aarch64	default	2018-12-13
Debian	Jessie	armv7l	default	2018-12-13
Debian	Jessie	aarch64	default	2018-12-13
Debian	Stretch	armv7l	default	2018-12-13
Debian	Stretch	aarch64	default	2018-12-13
Debian	Buster	armv7l	default	2018-12-13
Debian	Buster	aarch64	default	2018-12-13
Gentoo	stable	armv7l	default	2018-12-13
openSUSE	42.3	armv7l	default	2018-12-13
openSUSE	15.0	armv7l	default	2018-12-13
openSUSE	15.0	aarch64	default	2018-12-13
openSUSE	Tumbleweed	armv7l	default	2018-12-13
openSUSE	Tumbleweed	aarch64	default	2018-12-13
Sabayon	16	armv7l	default	2018-12-13
Ubuntu	Xenial	armv7l	default	2018-12-13
Ubuntu	Bionic	armv7l	default	2018-12-13
Ubuntu	Cosmic	armv7l	default	2018-12-13
Ubuntu	Cosmic	aarch64	default	2018-12-13