Nastavení IPv6, PPPoE

Prosím o pomoc. Asi jsem “někde na něco sáhnul” a nějak neumím najít cestu zpět.
Můj Turris 1.0 je připojen k internetu přes VDSL od T-Mobile. Před ním je ještě ten standardní T-Mobile modem/router ZyXEL VMG3312-T20A, v režimu bridge.
Vše funguje, s jedinou výjimkou. Turris samotný nemá přístup na IPv6 adresy. Test spojení ve Forrisu ukáže u IPv6 konektivity vykřičník, ping6 nebo jakýkoli pokus o IPv6 komunikaci z ssh konzole Turrisu vrátí ping6: sendto: Permission denied. Podotýkám - pod uživatelem root.
Jinak IPv6 komunikace funguje, ve všech ostatních zařízeních v síti. Všichni dostanou IPv6 adresu ze správného subprefixu, jako default routu pak ten Turris a bez problémů komunikují. Pátráním jsem nabyl dojmu, že jsem si někde nakopal IPv6 routování přímo na Turrisu, protože ip -6 route vrátí nějakou přebujelou odpověď:
default from 2001:1ae9:xxxx:4700::/56 via fe80::22e0:9cff:fe5d:8801 dev pppoe-wan proto static metric 512
default from 2001:1ae9:yyyy:628a::/64 via fe80::22e0:9cff:fe5d:8801 dev pppoe-wan proto static metric 512
2001:1ae9:xxxx:4700::/64 dev pppoe-wan proto static metric 1024 2001:1ae9:xxxx:4701::68 dev pppoe-wan proto kernel metric 256 2001:1ae9:xxxx:4701::/64 dev br-lan proto static metric 1024 unreachable 2001:1ae9:xxxx:4700::/56 dev lo proto static metric 2147483647 error -113 2001:1ae9:ff3:628a::/64 dev pppoe-wan proto static metric 256 fd68:6868:6868::/64 dev pppoe-wan proto static metric 1024 fd68:6868:6868:bbbb::/64 dev br-lan proto static metric 1024 unreachable fd68:6868:6868::/48 dev lo proto static metric 2147483647 error -113 fe80::/64 dev br-lan proto kernel metric 256 fe80::/64 dev eth2 proto kernel metric 256 fe80::/64 dev tap0 proto kernel metric 256 fe80::/10 dev pppoe-wan metric 1 fe80::/10 dev pppoe-wan proto kernel metric 256

Přičemž to 2001:1ae9:yyyy:628a::/64 a 2001:1ae9:xxxx:4700::/56 odpovídá prefixům přiděleným T-Mobile tomu PPPoE adaptéru. Přijde mi ta routovací tabulka nějak příliš složitá a falíruje mi tam ta unreachable 2001:1ae9:xxxx:4700::/56 na zařízení lo, to tam asi taky vnáší chaos. Ale netuším, jak jsem se k tomu všemu dostal.

Neporadil by někdo zkušenější, jak má vypadat vzorová konfigurace (buď obsah /etc/config/network, nebo výstup uci show network pro daný způsob připojení?

Děkuji

Ahoj, mám stejného operátora, pošlu jak u mě:

root@turris:~# ip -6 route
default from 2001:1ae9:2b8:ee00::/56 via fe80::fa13:8ff:fe24:3f11 dev pppoe-wan  proto static  metric 512
default from 2001:1ae9:ff2:e437::/64 via fe80::fa13:8ff:fe24:3f11 dev pppoe-wan  proto static  metric 512
2001:1ae9:2b8:ee00::/64 dev br-lan  proto static  metric 1024
unreachable 2001:1ae9:2b8:ee00::/56 dev lo  proto static  metric 2147483647  error -113
2001:1ae9:ff2:e437::/64 dev pppoe-wan  proto static  metric 256
fdab:fcc0:9468::/64 dev br-lan  proto static  metric 1024
unreachable fdab:fcc0:9468::/48 dev lo  proto static  metric 2147483647  error -113
fe80::/64 dev br-lan  proto kernel  metric 256
fe80::/64 dev eth2  proto kernel  metric 256
fe80::/64 dev wlan1  proto kernel  metric 256
fe80::/64 dev br-guest_turris  proto kernel  metric 256
fe80::/64 dev guest_turris_0  proto kernel  metric 256
fe80::/64 dev wlan0  proto kernel  metric 256
fe80::/10 dev pppoe-wan  metric 1
fe80::/10 dev pppoe-wan  proto kernel  metric 256



root@turris:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdab:fcc0:9468::/48'

config interface 'lan'
        option ifname 'eth0 eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '10.0.0.1'
        option _turris_mode 'managed'

config interface 'wan'
        option ifname 'eth2'
        option proto 'pppoe'
        option ipv6 '1'
        option username 'adsl'
        option password 'adsl'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'
        option noserverunicast '1'

config interface 'vpn'
        option ifname 'tun0'
        option proto 'static'
        option ipaddr '10.20.30.1'
        option netmask '255.255.255.0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4 '

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6'

config interface 'guest_turris'
        option enabled '1'
        option type 'bridge'
        option ifname 'guest_turris_0 guest_turris_1'
        option proto 'static'
        option ipaddr '10.111.222.1'
        option netmask '255.255.255.0'
        option bridge_empty '1'

config interface 'MODEM'
        option proto 'static'
        option ifname 'eth2'
        option ipaddr '192.168.0.2'
        option netmask '255.255.255.0'
        option delegate '0'
1 Like
root@turris:~# ping6 seznam.cz
PING seznam.cz (2a02:598:4444:1::1): 56 data bytes
64 bytes from 2a02:598:4444:1::1: seq=0 ttl=57 time=7.522 ms
64 bytes from 2a02:598:4444:1::1: seq=1 ttl=57 time=6.981 ms
64 bytes from 2a02:598:4444:1::1: seq=2 ttl=57 time=7.519 ms
64 bytes from 2a02:598:4444:1::1: seq=3 ttl=57 time=8.355 ms
64 bytes from 2a02:598:4444:1::1: seq=4 ttl=57 time=7.910 ms
64 bytes from 2a02:598:4444:1::1: seq=5 ttl=57 time=7.935 ms
64 bytes from 2a02:598:4444:1::1: seq=6 ttl=57 time=8.039 ms
^C
--- seznam.cz ping statistics ---
7 packets transmitted, 7 packets received, 0% packet loss
round-trip min/avg/max = 6.981/7.751/8.355 ms
1 Like

Díky. Takže ty unreachable routy na lo jsou zřejmě správně, mně to přišlo podezřelé. Zkusím to večer projít řádek po řádku - někde musí být zásadní rozdíl.
Jen pro informaci - to rozhraní ‘MODEM’ to je pro přístup na admin rozhraní toho VDSL modemu? To mám podobně a funguje. Na co jsem nepřišel bylo jak vysvětlit tomu modemu, že k internetu není připojen ani přes WAN port, ani přes ten VDSL modem ale že má default GW na Turrisu, přes LAN port. To prostě nechce chápat, takže třeba jeho WiFina je nevyužitelná, protože z ní vidí jen sám sebe. Stejně tak, pokud by se třeba snad chtěl aktualizovat, tak nemá jak, protože sám sebe nevidí připojeného k internetu.

Ano, rozhraní MODEM tě pustí zpět do modemu, mám to tam už dlouho, ani nevím jestli to ještě chodí.
Kdysi se to probíralo na starém foru:
https://www.turris.cz/forum/topic_show.pl%3Ftid=492.html

1 Like

Ještě jednou díky, pomohlo. Porovnáním jsem zjistil, že se mi nějak "perou"parametry wan6 rozhraní, které sice mělo option proto 'dhcpv6' ale zároveň taky nastavenou fixní IPv6 adresu, prefix a gateway. Ve výsledku to pak dělalo zmatek v routovacích tabulkách. Zřejmě něco mezi mojí židlí a Forrisem, u těhle user-friendly rozhraní člověk nikdy neví.
Ale teď už to chodí, děkuji.

2 Likes