NAS (samba) data transfer speed problems

Hi,

I have Turris Omnia with 2GB RAM with connected USB HDD (as sda) drive and configured as NAS. It work correctly, speed is usable (50/30 R/W via 5G WiFi). Problem is, that when I watch movies on Apple TV 4k (connected on 1GB LAN) and simultaneously writing data from PC over WiFi, Apple TV have problems with reading data from sda. It seems, that when writing at max speed from PC over WiFi (cca 30MB/s), reading speed is too slow.

I try to connect next USB drive (SSD as sdb) and writing some files to sda and some to sdb, it is same problem.

Where can be problem, or, how can I configure Turris to make set Apple TV priority higher?

Thanks.

Hi,

you cannot read and write at the same time. Maybe it could help if you tried to play around with prebuffering of videos on your TV or any client you are using, PC, laptop (if it is supported and have enough RAM), so you wont run out of your buffer while you are doing sometimes some other disk activities as well.

What you could also use is: ionice, you can prioritize some processes that are using the disk. However, as I checked it is not available on Turris repo, or maybe not even on OpenWRT, but do some resarch. You could also try to compile it here or just try to use it from a container.

Hi,

thanks for answer, but I hope, that it is a joke;) Only because of NAS function, that is better, as is on router like Asus RT-AC66U_b1 or RT-AC68U I buy Turris. On Asus routers I know, that read and write in one time is problem and NAS is disconnected, but on Turris too? I test Turris 2 days and for home use it is not good as I read. NAS is faster, but not stable. Now, I dont know why, my Apple TV each 5min freeze for few minutes and reading from NAS.

Thanks.

  1. What file system do you have? NTFS or any ext?
  2. what is system load during the situation you described?
  3. what is normal system load?
  4. what are top processes and load during this? (use htop)
  5. what is iowait and softirq during this situation?
1 Like
  1. NTFS
  2. I mean, that under 1.
  3. I mean, that still 1
  4. I try to check it, now I have disconected Turris and use Asus.
  5. Same as 5.

I can attach core log and system log too, maybe it help.

I would certainly try to avoid NTFS, especially if the drive will only be attached to a non-Windows system. (Just FYI, the FS might well be unrelated to what you experience.)

2 Likes

Let’s wait what 4. will tell you. I would expect maybe ucollect, suricata, pakond, kworker to be on the top.
Your TV use SMB or DLNA?

I use NTFS and I want to use NTFS in future too, because of Windows. Apple TV use SMB (I use Firecore Infuse Pro as movie player). I have DLNA server started too, because of Yamaha receiver only can use DLNA for music.

I know, that better is Synology, I had before, but I want All In One solution, because of dimensions and I dont need max performance, but still I need stability.

If you access the drive only over SMB, NTFS probably won’t help you, but I guess you want sometimes to disconnect it and attach to a Windows computer directly…

Yes, when I need “max performance”, I disconnect drive and attach it to Windows directly via USB-A/USB-C. Same situation is, when I need to give data to someone, or obtain data from someone.

Jinak, můžeme asi psát i česky, jsem si neuvědomil, že je to CZ projekt a většinou jsou zde CZ uživatelé a CZ podpora :slight_smile:

Díky.

1 Like

Assuming all current participants can use English well, I’d prefer to use that, as most Omnia users actually can’t use Czech IIRC. There are separate sections in forum for CZ.

2 Likes

It’s not about performance tweaks (for now) but as one of very first diagnostics (and usually performance is linked to reliability). If the problem disappears by changing to linux native FS then you know where to aim. We both me and @vcunat know what we speak about when it comes to linux and NTFS I think :wink:
It’s worth to try - trust me.

Btw: What is data rate for 4K on some video when you observe the problem?

I think it’s not a fault but a property

Data rate was low, 600MB for 1h video, so very low.

I know, that NTFS is sometimes problem (and as I see in core log and as you wrote, Turris have problems too), but still it is good and universal format, that can I use on my systems. I can read it on OSX too.

Here is something from core log.


[22517.289032] blk_update_request: critical medium error, dev sda, sector 2425602752
[22517.296560] Buffer I/O error on dev sda2, logical block 303167320, async page read
[22522.595965] sd 2:0:0:0: [sda] tag#0 UNKNOWN(0x2003) Result: hostbyte=0x00 driverbyte=0x08
[22522.595976] sd 2:0:0:0: [sda] tag#0 Sense Key : 0x3 [current]
[22522.595982] sd 2:0:0:0: [sda] tag#0 ASC=0x11 ASCQ=0x0
[22522.595989] sd 2:0:0:0: [sda] tag#0 CDB: opcode=0x88 88 00 00 00 00 00 90 93 c2 c0 00 00 00 08 00 00
[22522.595995] blk_update_request: critical medium error, dev sda, sector 2425602752
[22522.603512] Buffer I/O error on dev sda2, logical block 303167320, async page read
[22527.848149] sd 2:0:0:0: [sda] tag#0 UNKNOWN(0x2003) Result: hostbyte=0x00 driverbyte=0x08
[22527.848161] sd 2:0:0:0: [sda] tag#0 Sense Key : 0x3 [current]
[22527.848167] sd 2:0:0:0: [sda] tag#0 ASC=0x11 ASCQ=0x0
[22527.848174] sd 2:0:0:0: [sda] tag#0 CDB: opcode=0x88 88 00 00 00 00 00 90 93 c2 c0 00 00 00 08 00 00
[22527.848180] blk_update_request: critical medium error, dev sda, sector 2425602752
[22527.855712] Buffer I/O error on dev sda2, logical block 303167320, async page read

Apparently the drive is failing during writing, though I’m no good in finding out why exactly. I suppose I’d start by simple smartctl -H /dev/sd?

I believe NTFS is a well-designed FS (and it probably was one of the best at some point), but I wasn’t convinced about quality of non-Windows implementations, at least years ago. Maybe the FS is documented now, etc.

Google says for example this: https://www.linuxquestions.org/questions/linux-hardware-18/buffer-i-o-error-on-dev-sdb1-async-page-read-4175600715/
Maybe it is the cause maybe not.

Hi,

drive is OK, without errors, work with Windows, Asus router. Today I buyed Synology RT1900ac and Addonics NAS 4.0 adapter, drive work without problems (OK, via Addonics it was too slow, but it is adapter problem).

Now I testing Turris and it seems, that 1,5h after start it work without problems, I play video on Apple TV and from PC sending to drive 20GB file (17MB/s), at same time from drive to PC 15GB (17MB/s) file and at same time I compress 1160 files. This I repeat about 5 times, still OK. After that, I only watch Apple TV and problems start. It was not so extreme as fe days ago, only few times it freeze for few seconds. It was 5 times and after that it seems, that it work without problems. Diferent from first round of tests is, that before PC was connected via 5G WiFi, now I testing it via LAN. Maybe, it is overheating?

Here you have few screens from htop, top, iostat. In core log I dont see error, in log too.

Htop when Apple TV freeze.

Iostat when Apple TV freeze.

Top when Apple TV freeze.
top

Temps while transfer.
tur_temp

Htop while transfer.

EDIT: I now trying next test, 10GB video on Apple TV, sending file to NAS, downloading next 2 files from net to NAS, stress CPU/sensor to 107/109, without problems. I dont understand, it seems like randomly problem.

Thanks!

Nothing obvious from screen shots. Maybe only the temp is high (it is normal under load) and when 5G radio under load generates additional heat then it can cause probems mainly to radio whose temp. operating range is not so high.
And if I understand well the problem on TV exists randomly even when you’re not writing to disk.

disk:

  1. Could you confirm if time of errors in log matches with time of problem on TV?
  2. Are there are any errors in time when streamining on TV works properly?

temperature:
3. is cooling block really touching thermal tape on case?
4. if you remove the case for few days - problem persists or not?

other:
5. could you reproduce the same phenomenon by utilizing wifi as you did before?

I think you will need more time and testing to confirm real events causing the problem.

Hi,

it seems, that it was 2 problems.

  1. Because of problems, restarting and so, one file on drive was corrupted. Chkdsk not found that, but file was damaged and when I try to unrar it (it was part of few file in package), system disconnect drive, or drive was not accesable. This problem was same, while I connect drive to Windows PC, Synology RT1900. This was solved.

  2. Next problem I cannot detect. As I wrote, I turn on router after few hours of testing other router. It work correctly, Apple TV, iPhone, Windows PC are connected, movie loading on iPhone and Apple TV is fast. I saving files to and from drive simultaneously, still OK. Only what I found ist, that on PC, while I play video in MPC-HC, start playing is sometimes same, as on Apple TV and iPhone. Few seconds of initial loading, after that, video start, but after second it freeze for second and than continue of playing. After few hours, from PC I can still saving files at same speed, drive is still accesable (i downloading 10GB file at slow speed from net), but Apple TV start freezing. Sometimes cannot load file, or loading is slow or during playback, it freeze. I test play same video on Apple TV and iPhone simultaneously. It seems, that at same time (± few seconds because of cache) video freeze for few seconds (this was one time). But, mostly it is, that Apple TV freeze, or cannot load video and on iPhone I can start that video without problems at same time. At same time, Windows PC still can saving files to drive at full speed. I disable ipv6 in lan and wan too, still same.

I can accept, that problem is in Apple, but this is first time, that I have problems. I test it on Synology rt1900ac few days, without problems (yes, it is slower than Turris, but stable). Years I use Asus rt-ac68u or Asus rt-ac66u, without problems. LAN or WiFi, still same. Changing LAN ports, same.

About cooling - I try it, but today was temps under 100. I try it without case today too.

Thanks.

Here is System log. from latest router start.


Mod: Never ever post here your all syslog, which was quite long!

Use for example for posting logs pastebin.org / paste.ee or use BBCode [code] [*/code]

OK, sorry, thanks for edit.

There are some tips
https://www.samba.org/samba/docs/old/Samba3-HOWTO/speed.html