NAS and Samba, mount-chown-chmod vs smb.conf

I have to add this to smb.conf template, maybe it might help someone …
force user = sambauser
force directory mode = 0775
force create mode = 0664
allow insecure wide links = yes
unix extensions = no
wide links = yes ## that should be under ‘share’ block, but samba refuse to use it there
browseable = yes
local master=yes
preferred master = yes

Correspond share was given chown sambauser:users -R ./mnt/sda/myshare or chown sambauser:nogroup -R ./mnt/sda/myshare

And all worked as i wanted…

Transmission on a side was setup, prepared ‘watching’ folder (which is shared via samba). So now any user in my ‘workgroup’ just drop a torrent file there and it is downloaded and automatically shared back.

As i don’t want to share homes directly. At this point i just have to create on-demand correspond symlink for each user and set chown directly. What i found really strange at one point. With ‘home share’ set ON under specific user (with no-home, no-shell env) whole root structure was shown with full rights on client side. That a bit scared me.

Also on first try, wrong mounting cause me a lot of angry moments. My fail. I tried to share directly the mount point. Wrong way. Save your time and check first how you mount that drive (i did not need to change anything from ‘defaults’). There might be other ways how to achieve the same , but one might like nodev/noexec/nosuid options on mount, other might like ‘wide links’.

… as new to openWRT some of the ‘configs’ got me surprised initially … . because i acted like on normal linux, so edit smb.conf directly restart service and after reboot all gone. So not only template and 'active config’is there but sources for generating such (which has different notation and not all options are available…that’s why i put wide links to global, as in 'share’section it was not taken as valid during restart, in global , no issues (really don’t know why it is like that.).