My laptop gets no DNS

I think I have messed up my Turris config and would like help with resetting it.

I used to have a custom gw so I had my turris give the gw’s IP as DNS.

Now I’m back to a simple setup with just the Turris router and nothing else. I believe I have messed something up now because my laptop gets no functional DNS now, just an ipv6 address that does not work; fd3c:5a42:892c::1

So everytime I wake my laptop up I have to reset the DNS.

Where in the settings is this configured?

Maybe factory reset and and set up from scratch, if your (new desired) configuration isn’t something complex that’s hard to reapply? Omnia - Turris Documentation

I’m sorry but I’ll have to re group and come back at a later time. It seems the issue is weirder than I thought.

It only affects my Fedora laptop. I have chromecasts, cellphones and tablets all working fine by default, and my Windows 10 laptop gets as DNS, which is the turris router IP.

My fedora laptop is the only one getting this ipv6 address. And also the ipv6 address does work when I run resolvectl query.

The actual behavior I’m seeing is that when I wake my Fedora laptop up from sleep I get no network until I run resolvectl dns NIC But I just tested systemctl restart systemd-resolved; and it resets the DNS back to the ipv6 address, then resolvectl query works just fine.

Lastly, on the landing page of Luci, the dashboard, it shows as IPv4 DNS my old GW IP, and my ISP DNS. This is very wrong but I have no idea where to fix it.

So clearly something is weird at wake up. I’ll have to do more troubleshooting and return.

This topic was automatically closed after 60 days. New replies are no longer allowed.