Multiple Nextcloud installation issues

According to Nextcloud installation documentation: https://docs.turris.cz/geek/nextcloud/nextcloud/ the installation should be available through Foris “Updater” tab. However Nextcloud is not visible for me on this tab.
Q: Any hint how I can fix this?

Further more I have tried to install it manually (according the doc linked above). Installed the package ‘nextcloud-install’, however after the installation i received ‘503’ error on turris.lan/nextcloud. So i run nextcloud_install script manually. This deviates from the documentation.
Q: Can anybody tell me if the doc is outdated or did i misunderstood something?

While running the installation I have also received the following error:

[Warning] option 'table_open_cache': unsigned value 4 adjusted to 10
/usr/bin/mysql_install_db: line 1: hostname: not found
WARNING: The host '' could not be looked up with /usr/bin/resolveip.
This probably means that your libc libraries are not 100 % compatible
with this binary MariaDB version. The MariaDB daemon, mysqld, should work
normally with the exception that host name resolving will not work.
This means that you should use IP addresses instead of hostnames
when specifying MariaDB privileges !
Installing MariaDB/MySQL system tables in '/srv/mysql' ...

I think this will bite me in the “back” after at some point…
Q: Can anybody tell me what is wrong here? I assume a misconfiguration of turris.

Well at least nextcloud starts and runs so far… However when i wanted to change my avatar it spins endless. the log show me:

Error: Call to undefined function OC\Avatar\imagettfbbox()
...
Error: Call to undefined function OC\Avatar\imagettfbbox() at /srv/www/nextcloud/lib/private/Avatar/Avatar.php#218

So it seems shome php modules are missing.
Q: Any idea how can i fix this?

Thank you in advance for any hints.

Here, you should have stopped and ask the community. We had a similar thread…
Therefore, which Foris (and which Turris OS) version do you have? Because your device might be in an unknown state now, I recommend to go for rescue mode 6… after that you should have the latest version(s). Do you have the Nextcloud option now?

Thank you for the hints to the other thread & doc :slight_smile:

What do you mean with “unknown state”? did a prior update gone wrong? or is it a misconfiguration i did? and if is should reset it can i still use my current configuration? or do i need to manually repeat all of my configs?

foris version: 100.5
Turris OS version 3.11.13

Puh, I am not sure if Nextcloud is supported there at all. Perhaps an official member is able to comment on that. I had Turris 4.0.0 and no Nextcloud. I updated, actually I recused to Turris 4.0.3 and Nextcloud is there.