MTU settings broken

This is my /etc/config/network file:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde2:ccf3:90a6::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option bridge_empty '1'
	option mtu '1478'
	list ifname 'lan0'
	list ifname 'lan1'
	list ifname 'lan2'
	list ifname 'lan3'
	list ifname 'lan4'
    
config interface 'wan'
	option ifname 'eth2'
	option proto 'dhcp'
	option ipv6 '1'
	option mtu '1478'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname '@wan'
    option mtu '1478'

config interface 'guest_turris'
	option enabled '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '10.111.222.1'
	option netmask '255.255.255.0'
	option bridge_empty '1'

config interface 'vpn_turris'
	option enabled '1'
	option ifname 'tun_turris'
	option proto 'none'
	option auto '1'

config interface 'Xbox'
	option proto '6in4'
    option mtu '1478'

If I look at these interfaces from the Luci menu Network>Interfaces, they show the interface that my computer is connected to as having an MTU of 1478. Next, I go on my computer, open a command prompt and type ping www.reddit.com -f -l 1400, I get dropped packages:

Reply from 192.168.1.1: Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.

My Xbox complains about an MTU issue as well, so I doubt it’s the PC that’s incorrectly set up. Is there any other place in OpenWRT that might override the MTU settings?

Edit: I’ve removed all “1478” settings, and the interfaces now revert back to the default of 1500. In Windows, I run the command netsh interface ipv6 show subinterface. This shows all interfaces again with an MTU of 1500. But the ping command still fails. Playing around with the number, the max package size I can send out appears to be set to 1252… Where does this number come from???

Could this be from wifi? In the default config, wired and wireless interfaces are bridged in Turris, and a bridge automatically uses the lowest MTU set on any of the bridged devices.

This looks like you internet access is somehow limited:
1252 with ping/ICMP echo requests indicates IP payloads of 1252+8 = 1260 if we add 20 bytes for an IPv4 header we find 1280 bytes which just happens to be the smallest maximal MTU specified for IPv6.
This could indicate some sub-optimal IPv6 related configuration by your ISP.
Which ISP if I may ask?

Thanks for your time @moeller0 . To rule out my ISP, I connected the PC and Xbox directly to the modem. Doing this, both functioned normally again. I assume the problem is with the router then. After this I factory resetted my Turris (3 LEDs solidly turned on before releasing the reset button), and it still doesn’t work… I’m still getting the same issues as before.

Thanks for the tip. I’ve done a factory reset, no devices connected to WiFi afterwards. I still get the same issue.

This isn’t dependent on the number of connected wifi clients. It would be because of the MTU settings of the wifi interface of Turris. Can you post the output of ifconfig? I think the MTUs should be printed there…

Thanks for testing this, odd! So “ping www.reddit.com -f -l 1400” directly from the PC works as expected? What is the largest -l number you get valid ICMP responses?

Do you see this to all ping targets? What if you reboot the router and ping your ISP’s DNS servers to deduce the MTU? Still the same issue

Ahhh! I printed the ifconfig, and got this output:

br-guest_turris Link encap:Ethernet  HWaddr 4A:3E:89:E6:55:52

          inet addr:10.111.222.1  Bcast:10.111.222.255  Mask:255.255.255.0

          UP BROADCAST MULTICAST  MTU:1500  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

br-lan    Link encap:Ethernet  HWaddr 04:F0:21:23:24:49

          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0

          inet6 addr: 2001:1c00:1014:c000::1/60 Scope:Global

          inet6 addr: fe80::6f0:21ff:fe24:13b5/64 Scope:Link

          inet6 addr: fd0b:7453:b166::1/60 Scope:Global

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:5296853 errors:0 dropped:0 overruns:0 frame:0

          TX packets:8004456 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:1047627807 (999.0 MiB)  TX bytes:21109875067 (19.6 GiB)

ds-wan6_4 Link encap:UNSPEC  HWaddr 20-01-1C-00-10-00-00-00-00-00-00-00-00-00-00-00

          inet addr:192.0.0.2  P-t-P:192.0.0.1  Mask:255.255.255.255

          inet6 addr: fe80::8c6f:62ff:fe44:fed9/64 Scope:Link

          UP POINTOPOINT RUNNING NOARP  MTU:1280  Metric:1

          RX packets:1801374 errors:0 dropped:0 overruns:0 frame:0

          TX packets:1747812 errors:14 dropped:14 overruns:0 carrier:14

          collisions:0 txqueuelen:1000

          RX bytes:3703744540 (3.4 GiB)  TX bytes:373940675 (356.6 MiB)

eth0      Link encap:Ethernet  HWaddr D8:58:D7:00:2D:02

          inet6 addr: fe80::da58:d7ff:fe00:2d02/64 Scope:Link

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:110943 errors:0 dropped:0 overruns:0 frame:0

          TX packets:314026 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:532

          RX bytes:31818837 (30.3 MiB)  TX bytes:42113560 (40.1 MiB)

          Interrupt:37

eth1      Link encap:Ethernet  HWaddr D8:58:D7:00:2D:00

          inet6 addr: fe80::da58:d7ff:fe00:2d00/64 Scope:Link

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:3519690 errors:0 dropped:0 overruns:0 frame:0

          TX packets:11457611 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:532

          RX bytes:372907746 (355.6 MiB)  TX bytes:16294967837 (15.1 GiB)

          Interrupt:38

eth2      Link encap:Ethernet  HWaddr D8:58:D7:00:2D:01

          inet addr:83.84.157.176  Bcast:83.84.157.255  Mask:255.255.254.0

          inet6 addr: fe80::da58:d7ff:fe00:2d01/64 Scope:Link

          inet6 addr: 2001:1c00:1000:0:3172:f62:1617:f48d/128 Scope:Global

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:20076108 errors:0 dropped:0 overruns:0 frame:0

          TX packets:5037335 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:532

          RX bytes:22190325450 (20.6 GiB)  TX bytes:1143514665 (1.0 GiB)

          Interrupt:39

lan0      Link encap:Ethernet  HWaddr D8:58:D7:00:2D:00

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:1326483 errors:0 dropped:34 overruns:0 frame:0

          TX packets:2216676 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:101500129 (96.7 MiB)  TX bytes:3303264069 (3.0 GiB)

lan1      Link encap:Ethernet  HWaddr D8:58:D7:00:2D:00

          UP BROADCAST MULTICAST  MTU:1500  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan2      Link encap:Ethernet  HWaddr D8:58:D7:00:2D:00

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:289479 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:0 (0.0 B)  TX bytes:47785491 (45.5 MiB)

lan3      Link encap:Ethernet  HWaddr D8:58:D7:00:2D:00

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:2189433 errors:0 dropped:0 overruns:0 frame:0

          TX packets:8951448 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:193776889 (184.7 MiB)  TX bytes:12852256557 (11.9 GiB)

lan4      Link encap:Ethernet  HWaddr D8:58:D7:00:2D:02

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:114711 errors:0 dropped:0 overruns:0 frame:0

          TX packets:314019 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:29574983 (28.2 MiB)  TX bytes:39600582 (37.7 MiB)

lo        Link encap:Local Loopback

          inet addr:127.0.0.1  Mask:255.0.0.0

          inet6 addr: ::1/128 Scope:Host

          UP LOOPBACK RUNNING  MTU:65536  Metric:1

          RX packets:1229413 errors:0 dropped:0 overruns:0 frame:0

          TX packets:1229413 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:523898782 (499.6 MiB)  TX bytes:523898782 (499.6 MiB)

wlan0     Link encap:Ethernet  HWaddr 04:F0:21:24:13:B5

          inet6 addr: fe80::6f0:21ff:fe24:13b5/64 Scope:Link

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:2870370 errors:0 dropped:0 overruns:0 frame:0

          TX packets:6078940 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:858929501 (819.1 MiB)  TX bytes:5923462545 (5.5 GiB)

wlan1     Link encap:Ethernet  HWaddr 04:F0:21:23:24:49

          inet6 addr: fe80::6f0:21ff:fe23:2449/64 Scope:Link

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:23145 errors:0 dropped:0 overruns:0 frame:0

          TX packets:194027 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:3747488 (3.5 MiB)  TX bytes:36492797 (34.8 MiB)

Note the ds-wan6_4 interface, which is set to 1280. Looking at this in Luci I see this:

I can’t set anything for this interface, and I can’t delete it either. According to ifconfig it’s the only interface with an MTU of 1280. What is this interface and how do I edit it?

What are your IPv6 settings in reforis? I think it should be related to them. I have DHCPv6 selected and I have no such interface.

Same, DHCPv6 automatic configuration. I’ve fixed the issue. I used the command ifconfig <Interface_name> mtu <mtu_size> up and set that interface to 1500. Now my PC and Xbox no longer complain about MTU. It’s weird I had to do it this way, or that a factory reset didn’t fix this, but yeah. Thanks for your help in finding it! Without you I wouldn’t have noticed the ifconfig output, so thanks a ton.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.