Msata ssd not recognized


I’ve checked several threads, wiki documentation, but still can’t get Omnia Turris to recogize the following msata device: SUNBOW mSATA Mini PCIe 240 GB 256 GB M3 Series SSD (it was working fine in a Lenovo laptop – running Debian GNU/Linux – no problem)

The NAS option in Forris UI is activated

I’ve tried adding the following packages (just in case; apparently the SSD controller is a SMI2256K, and wasn’t sure if maybe some module was missing) :


However, I’ve never been able to see anything else than:

$ grep -v ram /proc/partitions
major minor  #blocks  name

  31        0       1024 mtdblock0
  31        1       7168 mtdblock1
 179        0    7634944 mmcblk0
 179        1    7633920 mmcblk0p1
 179       24       4096 mmcblk0rpmb
 179       16       4096 mmcblk0boot1
 179        8       4096 mmcblk0boot0

And then I took it apart, tried the 43rd pin thing… but same same.

Also, FWIW, $ dmesg | grep ata2 never shows up any hits…

Last, Omnia just updated itself last night; normally running correct version for everything.

So, I’m out of ideas… any help/idea welcome

I had had the same issue with SSD from Lenovo laptop. Luckily the 43rd pin thing worked for me, but only after several tries. The masking tape was moving and I had to experiment a bit to cover the right pin only.

Are you positive that you were masking the 43rd pin only and the tape did not moved when inserting in to the slot?

I am having this same issue. I would try the 43rd pin fix, except that I can’t find exact steps. How do I “disconnect pin 43”? Pictures I find show tape, but don’t show connection to ground. I have no hits in /var/log/messages (dmesg); also, this SSD worked in correct slot when the radios were not. As soon as the radios began working, the SSD disappeared.

I would have chosen another topic, but they were all closed once people said, oh, the 43rd pin worked for me. I’d be OK with that if I could figure it out.