mSATA NAS setup - solved

I set up a mSATA as NAS with following steps:

0 install the mSATA module at the right mPCIe slot
1 create one primary partition with: fdisk /dev/sda
2 format with: mkfs.ext4 /dev/sda1

3 In LuCI under System/Mount_Points/Mounted_file_systems is see:

/dev/sda1 filesystem with the mount point: /mnt/sda1 and Mount_Points/Enabled is checked.

4 In LuCI I configure under Services/Network_Shares/Shared_Directories:

name: NAS
path: /mnt/sda1
Allow guests and Permissions 0777

/etc/init.d/samba enable
/etc/init.d/samba start

in Windows:


1 Like