mSATA drive not detected correctly


I buy a Netac NT01N5M-002T-M3X 2TB mSATA drive. But when connected to Turris Omnia, it is not detected correctly and with a volume of 1GB.

root@router:~# lsblk -n -S
sda  0:0:0:0    disk ATA      SM59XT2A-10-00K2 0308        sata
root@router:~# fdisk -l
Disk /dev/sda: 1023.75 MiB, 1073479680 bytes, 2096640 sectors
Disk model: SM59XT2A-10-00K2
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

When I try to format via reForis I get an error:

Disk formatting failed, try turning it off and on again.

Technical details: btrfs-progs v5.11
See for more information.

No valid Btrfs found on /dev/sda
ERROR: open ctree failed

When connected to a Windows computer via a USB adapter, the disk is detected correctly and has a capacity of 1.82TB.

Any ideas? Driver?
I will be grateful for any help.

For me it did not work out of the box, I followed Switch to force mSata - #12 by jhuebner (had to apply isolation tape to pin 43 of the mSATA connector) and it worked.

Thanks, I already thought about it. This is the method I tried first, it doesn’t affect the drive definition. In both options, the disk is defined the same way and does not work.