Mpd doesn’t start from luci or autostart

I’ve had mpd (package mpd-mini), usb drivers, sound drivers and codecs and use a usb sound card on the omnia to play music from my NAS on my stereo. This has worked flawlessly for years. Now for the past couple of days, mpd doesn’t autostart anymore, although it is enabled in the autostart list in Luci. I cannot start it manually in Luci either.
However, connecting via ssh as root and then starting mpd works. What could be the reason for mpd not to work from autostart / Luci? Maybe a connection with recent upgrades?

Is it installed correctly ?
Is it visible in the processes ?
Is it visible in Luci -System - Startup - Initscripts ?

mpd and the necessary drivers are installed correctly and mpd is visible and enabled under luci - system - startup.
Despite being enabled, mpd doesn’t start after boot, and therefor is not visible under luci - status - processes. And clicking the start or restart button in luci - system - startup doesn’t do anything.

It used to work until recently.

However, I can ssh into omnia as root and start mpd manually, then it works and it becomes visible under luci - status - processes. I can then connect and play music.

The question is: What has changed recently? I haven’t changed the configuration in years. TurrisOS version is 7.0.0.

After reboot, I see this error message in the system log:

omnia mpd[6322]: exception: Failed to open ‘/etc/mpd.conf’: Permission denied

which explains why mpd doesn’t run on autostart. The configuration file is owned by root. After setting

chmod 664 /etc/mpd.conf

and rebooting, I get permission errors for other files created by mpd. I haven’t changed the configuration or any of the other files, so I assume mpd is now (since the update) executed as a different user. Could that be the case?

Not sure why the errors occur and mpd doesn’t autostart when enabled in the Initscripts. Anyway: Adding mpd to rc.local (in the “Local startup” tab) works.

1 Like