mPCIe slots and 802.11AC wave 2

@Jan.H could you please state the actual status of this wifi-module:

Is the slot compatible?
Does the new v.3.8-driver handle all functionalities?!
Please - this is ongoing for 6 months now…

1 Like

At the moment there are two similiar cards available:
22 MU-MIMO with 2SS at 80 MHz ⇨ 867 MBit bandwidth
WLE650V5-18: http://www.compexshop.com/product_info.php/cPath/104_105/products_id/149
WLE650V5-25: http://www.compexshop.com/product_info.php/cPath/104_105/products_id/194
4
4 MU-MIMO with 4SS at 80 MHz or 2SS at 160 MHz ⇨ 1733 MBit bandwidth
WLE1216V5-23: http://www.compexshop.com/product_info.php/cPath/104_105/products_id/475
WLE1216V5-20: http://www.compexshop.com/product_info.php/cPath/104_105/products_id/486
Looking to the product specs, I cannot really tell the difference, only that *-25 and *-20 have higher product-IDs and therefore maybe later developments?

Concerning the throughput the theoretical 1,73GB/s should be no problem for the TO pcie 1.0-interface, right?

1 Like

I would advise you to go with the WLE650V5-25 if you want to have the best TX power per radio chain. It is a perfect card for countries with a EIRP of 100mW ( 20dBm ).

Say that you set an output power of 17 dBm and that you use 2 antennas (x2 the power so +3 dB) with 2 dB lost due to the antenna patchs and 3 dB lost due to the diplexers used by the Omnia and that the antennas for the omnia have a passive gain of 5 dB:
17+3-3-2+5 … 20 dBm

Furthermore, notebooks with 3 radio chains are not common and I do not think I ever met one with 4. So you migth as well spare you the trouble with the power hogs that are those 4*4 cards.

According to my experience, you will not met any problem with the Turris PCIe version 1.0 x1 interface of the mPCIe slot. But it is true that an official answer is long overdue.

I bought the WLE650V5-25 about two weeks ago and tested it.

First of all there are two different versions of the WLE650V5-25 card on the market. The earlier modules use
the QCA8886 and the newer once the QCA9888 - I got one with the QCA9888 SoC.

I tested this module with all sorts of ath10k drivers and none really worked. The best one was this one:

http://www.candelatech.com/downloads/ath10k-9888-10-4/firmware-5-ct-full-community.bin

With this driver the card works but with a very weak signal strenght. Even with cables and antennas
attachd to it - the cards behaves like there would be no atennas attached to to card at all.

If someone has an idea what the cause might be, I am happy to continue testing and to post the findings.

@zoverl: as you advertise the -25 - did you get it working? See @Tom’s post above.
For me the -25-card is of no use as it is not capable of using 160MHz and therefore with it you cannot unleash the full power of wave2.
The 4
4-cards do not require to have a 4
4 wifi-client as they are using 2SS at 160 MHz!
But they are not completely useable as atm there’s no laptop wifi-card available capable of handling 160 MHz-streams, right? The Intel 9260 has been long advertised, but is still not on the market.

So I will definitely go with a 4*4-card but not before Intel releases the 9260.

@Tom: this maybe because of a card defect, I had something like that before with a Intel card :frowning:

I was about to write a rant about Qualcomm (and others) doing their best to screw up their range of WiFi cards.

But I think this high severity vulnerability will keep me busy for the whole week :
https://forum.turris.cz/t/major-wpa2-vulnerability-to-be-disclosed/5363/3

Wow… Is this within the wifi-card-firmware? If yes - can it be patched from within openwrt?

The bug is not in any firmware. It is in protocol layer. But protocol is likely handled by firmware.

Ok. So the drivers need to be fixed, right?

The Debian project published today an update for the hostapd and the wpasupplicant packages, the software used to make an access point and a sta with a wireless NIC.

So it may be enough to update those softwares without any change to the drivers.

From what I understand, if either the sta or the access point was updated, the vulnerability can not be exploited. To be verified.

1 Like

Hi Tom,

i just installed a WLE650V5-25 5GHz card into my Turris omnia.

Currently the card isnt working.
Do you have updates on the Firmware issue, or links how to install those .bin files?

Best regards,

georg

Hi @Georg_Duees,

I returned my first WLE650V5-25 and tried a second
WLE650V5-25 card and all sorts of ath10k drivers - no luck.

I got it working but the signal was so weak - like no antennas would be attached to it.

You only recognize that the card is working when you open the case and hold a device
(e.g. iPhone) very close to the card.

Tom

HI
i work with WLE650V5-18. I simply install the packet ath10k-firmware-qca9888 (opkg update; opkg install ath10k-firmware-qca9888).

Roland

Hi, I am interested in getting two of those cards WLE1216V5-20 and have two 5G channels, can you please keep us updated on the progress of your testing and availability of drivers? I am also not 100% sure about the original configuration, is it possible to keep the dual channel 2.4/5 GHz card in and add this one as a third channel?

Thank you.

Hello,
so I have a good news. My colleague wrote to me that the card had already arrived. We are looking forward to the tests.
As soon as I know more, I’m sure to say, because more people enjoy the practical results.

2 Likes

Thanks for your answer.
Can you already tell us, which cards you ordered?

Any news about WLE1216V5-20?

So far, we’re in a state where the card is running, but all the edits to support new modes are not ready yet compared to the current card so the support can be added to the system. The addition is working, unfortunately now I am not able to say when it will go into production.

Did you get chance to check/measure advantage of mu-mimo versus default 5G card?