MOX rescue modes

If someone could not find it, here is a link .

The most used mode to start with the first version of MOX A is Rescue Mode 6. Just plug the LAN cable into the network where DHCP and Internet access is enabled, insert an empty SD card and Turris OS installs itself from the Internet.

1 Like

And there is the same translated to Czech.

A zde je to samé přeložené do češtiny.


Given a serial console, is there a way to avoid the button-pushing/blinking. Particularly since that button is really difficult to push if you have covers off. A u-boot invocation that gets one right into rescue-mode X?

I see that I can start it from u-boot with “run rescue_bootcmd”, and I see the prompts to change modes.
Can I just switch directly to the mode I want? I’m not that good at counting LED flashes.

I read through the shell scripts from the rescue container on the MOX (in the build tree, as: …/turris-build/build/feeds/turrispackages/hardware/rescue-image/files/ ) and it seemed that if one adds “rescue_mode=3” to the kernel command line, via, for instance:

setenv rescue_args "console=ttyMV0,115200 earlycon=ar3700_uart,0xd0012000 rescue_mode=3"

and then boot with

run rescue_bootcmd

it boots, but alas, the script fails, because I think it runs before /proc is mounted:

[    4.225350] mmc0: new ultra high speed SDR104 SDIO card at address 0001
sed: /proc/cmdline: No such file or directory
Initializing the system

Too bad.

well, it seems that init() does mount /proc, and this happens before fetch_cmd_mode, but I wonder if the kernel config does not have /proc/cmdline? I don’t recall a kernel config to disable /proc/cmdline.

What’s even worse is the image in the SPI flash seems to be bad, too

sed: /proc/cmdline: No such file or directory
Initializing the system
[    4.728193] mmc1: new ultra high speed SDR104 SDHC card at address aaaa
[    4.735160] mmcblk1: mmc1:aaaa SA16G 14.8 GiB
[    4.742634]  mmcblk1: p1
Now is your chance to change a mode from 1 to something else, press the button to do so
[    5.291453] watchdog: watchdog0: nowayout prevents watchdog being stopped!
[    5.298594] watchdog: watchdog0: watchdog did not stop!
expr: syntax error
Waiting for s ...
6s left
Rebooting as requested!