Mox Power-WiFi unreachable after "netboot" and then reflash from internet

I have bought two Mox PowerWiFI and one Omnia 2020 to replace my home network hardware with these.
After a few days of running one MOX as an AP, I tried the “network boot” option, for I wanted to pair both MOX with my Omnia in an easy way and have wifi coverage.
That failed; both Mox were recognized and paired with the omnia just fine, but wouldn´t put out a WiFi signal and couldn´t be configured further; LuCI would give out the message that “device has no WiFi”… I tried the workaround mentioned in this thread, but it didn´t change anything, the Moxes did not offer any WiFi signal.

So I wanted to switch back to “Full AP” mode. Since there were some updates in the meantime, I thought Mox Reset Mode No. 6, flash from the internet would be a great idea.
Did this on both devices, waited for them to show up on my local Lan on my Omnia… and… they DO show up for a few seconds. the MAC-address starting with D8 is theirs, they get an IP via DHCP… but can´t be reached via their IP in browser, not via SSH, and after a few seconds, they both just vanish from the LAN.

Then I downloaded mox-medkit-latest.tar.gz, put it onto the sd card (fat32 formatted) and used rescue mode 4, flash from USB / SD card.
Behaviour stayed the same, device is not accessible.

Then I tried flashing from an usb stick. Same outcome.

Then I connected the MOX directly to my PC, changed my PCs IP to and tried to reach the mox (after fresh boot) at . Nothing via browser, not reachable via SSH.

THEN I tried rescue mode 5, unsecure SSH. That finally let me enter the Mox, so i know it´s not completely dead. But I don´t know what to do with that mode, to be honest.

Other things I tried : different Lan cables, differend power adapters, differend SD cards, and everything on two different MOX.

As you might guess, I am not the most advanced guy around here, so please, if you need logs to help me further or if there is any other way to get my MOX back to work, tell me.
I am absolutely out of ideas now.

Omnia is on 5.3.5, the mox medkit should be 202201250706.