Mox Power-WiFi First Start not booting


I"m new to turris mox. I bought an Mox Power-Wifi Set and expanded it with a MOX C Modul, so in fact it is like the mox classic set.

When I first powered it on, only the red led shines. But it doesn"t change to blinking. So I guess the MOX isn’t booting.

I searched around in this forum and found the topic Newbie questions now that I’ve finally gotten my Mox Pocket WiFi connected and did the flashing of the sd-card via the manualy method but nothing changed.

I tried a few times to press the reset button for over 4 seconds and sometime over 30 seconds because I found an external description to make a factory reset via pressing it 30 seconds.

When I tried to boot the MOX I have connected it via LAN to my notebook and on some tries I connected it to my switch too.

Should I try to boot it without any LAN cables connected? I don’t know how I get the MOX in a correct boot state.

For better understanding. I want to add the mox into an existing network, so I want to use it as an second router to expand my wifi network to a second building.


Did you try to connect MOX and the computer directly (without connecting to the existing network)?

What do you think about Ethernetless configuration (also suitable for existing networks)?

Hi viktor,

yes I also tried to only connect the computer via LAN or WAN with the mox.

In the morning I also tried just to power on the mox without any LAN cables, but also just the red led is shining steady.

What do you think about Ethernetless configuration (also suitable for existing networks)?

No, but I think also for this configuration mox has to boot up first correctly, or?


please proceed with these steps: Support - Turris Documentation

cc: @Stepan


yes I opened a ticket [turris-L1 #1457967]


So after following the newer instructions for flashing the sd-card and many many reset tries and waiting time, I got finaly booted the mox.

I have to look if I can reduce the boot time because now I had to wait over 16min to get the router ready.

Thanks you and the support for some hints.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.