Mox hardware problems solved after reassembly

I am a happy user of Turris Omnia. Recently I received my classic mox (A+B+C) but I was really disappointed. It just didn’t work. No dhcp in ethernet module C. I even tried with static IP and captured traffic but nothing changed.
After that I tried to connect my PC to the ethernet in module A. Same problems.
I read the forum and found a good suggestion: disconnect all the modules but A. First sign of light. I could do a basic configuration after many resets 4. But when I connected modules B and C stopped to work.
After more than two hours of testing different things I decided to open the router and separate all the pieces. I wanted to make sure that everything was well connected (I didnt wan’t to think about a real hardware problem). And that was the solution. Everything worked after the reassembly. Even the PoE.
Maybe the shipping was too hard for the Mox. Hope this helps someone

2 Likes

My router arrived with SDIO wifi cables disconected. I also suspect rough handling in shipping.
Maybe opening the router and checking everything first can prevent a lot of issues. I can imagine anything else could came loose if it had been shipped somewhere else than Prague.