MOX: Device is not active (Qualcomm Atheros QCA9880 802.11acbgn)

Hi,

did scan on Qualcomm Atheros QCA9880 802.11acbgn to see whatever wifi´s around have channels, then I set channel from 36 to auto -> Save & Apply and since then, it´s saying “Device is not active” and I cannot find my wifi. I also tried to put channel back to 36 and I’ve also tried restart button on Qualcomm Atheros QCA9880 802.11acbgn.

This is in LuCI (Powered by LuCI branch (git-20.186.82389-282dbf8) / TurrisOS 5.0.3 73e0ea1ea964f27097ff4009b5d55f31a40d2932)

If you used LUCI for this, you should ensure you have correctly set the country. If you used FORIS (and you have set correctly region/time stuff) it is taken care off. Both interacts with /etc/config/wireless (each wifi-device should have option country 'XX' , where XX is code of your country and sometimes(after wifi is set in Foris and user jumps into Luci …and edit) Luci cause that country is not set (there you have to set it extra, you will see it in “greyish” color). Which is essential for radios to work (some legal stuff, like limits for radio0/1 …you can change, each country has own technical regulation, power, distance, channels … and so on).

issuing wifi status in terminal should generate used setup/status of each radio/wifi, check if you have the country there.

(btw: i do not know what MOX has in Foris/Luci available, i assume it is pretty same as in Omnia)

Hi,

yep, I used LuCI for it. Country is actually there for both radios. Any other idea?

Post the uci wireless config and output of wifi status (withouth the passwords/keys)
you can run wifi reload and check the systemlog …eventually /etc/init.d/network can be used to restart whole network …
You can also check hostapd process/setup.

Hi,

here are the configs:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option macaddr '<mac:add:ress>'
        option country 'CZ'
        option htmode 'VHT20'
        option channel '36'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Turris_5'
        option hidden '1'
        option encryption 'psk2+ccmp'
        option wpa_group_rekey '86400'
        option key '<password>'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option macaddr '<mac:add:ress>'
        option htmode 'VHT80'
        option disabled '1'
        option country 'CZ'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'Turris'
        option encryption 'none'
        option disabled '1'

config wifi-iface 'guest_iface_0'
        option disabled '1'
        option device 'radio0'
{
        "radio0": {
                "up": false,
                "pending": false,
                "autostart": true,
                "disabled": false,
                "retry_setup_failed": true,
                "config": {
                        "hwmode": "11a",
                        "macaddr": "<mac:add:ress>",
                        "country": "CZ",
                        "htmode": "VHT20",
                        "channel": "36"
                },
                "interfaces": [
                        {
                                "section": "default_radio0",
                                "config": {
                                        "mode": "ap",
                                        "ssid": "Turris_5",
                                        "hidden": true,
                                        "encryption": "psk2+ccmp",
                                        "wpa_group_rekey": 86400,
                                        "key": "<password>",
                                        "network": [
                                                "lan"
                                        ],
                                        "mode": "ap"
                                }
                        }
                ]
        },
        "radio1": {
                "up": false,
                "pending": false,
                "autostart": true,
                "disabled": true,
                "retry_setup_failed": false,
                "config": {
                        "channel": "36",
                        "hwmode": "11a",
                        "macaddr": "<mac:add:ress>",
                        "htmode": "VHT80",
                        "country": "CZ",
                        "disabled": true
                },
                "interfaces": [

                ]
        }
}
# wifi reload
'radio1' is disabled
'radio1' is disabled

Didn’t fix the problem. Nothing new is in /var/log/messages.

Restart of whole network fixed that. I tried to change it again, but after one minute, the WLAN was up again. I will try it during the weekend if I will be able to simulate it again and gather logs from /var/log/messages.

https://openwrt.org/docs/guide-user/network/wifi/basic#common_options1 option disabled:

Disables the radio adapter if set to 1 . Removing this option or setting it to 0 will enable the adapter

Delete option disabled '1' in /etc/config/wireless save it and issue uci commit wireless command with following restart of wireless service.

Hey,

so I hit this issue again more less… I find out that WiFi is not broadcasting, so I went to LuCI to check… all looked ok, so I tried hit restart on Qualcomm Atheros QCA9880 device. Since then, in LuCI interface with my wifi looks disabled.

How I can help with debugging this to find the rootcause to fix the bug? Or it´s HW issue? Understand me that having stable wifi like this at home is not a best experience to have :slight_smile:. Luckily, I am not using this router so far… but I will in a month, so I would like to have it stable instead of getting divorce papers :smiley:

Configs here:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option macaddr '<mac:add:ress>'
        option country 'CZ'
        option htmode 'VHT20'
        option channel '120'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Turris_5'
        option hidden '1'
        option encryption 'psk2+ccmp'
        option wpa_group_rekey '86400'
        option key '<password>'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option macaddr '<mac:add:ress>'
        option htmode 'VHT80'
        option disabled '1'
        option country 'CZ'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'Turris'
        option encryption 'none'
        option disabled '1'

config wifi-iface 'guest_iface_0'
        option disabled '1'
        option device 'radio0'

Wifi status:

{
        "radio0": {
                "up": false,
                "pending": false,
                "autostart": true,
                "disabled": false,
                "retry_setup_failed": true,
                "config": {
                        "hwmode": "11a",
                        "macaddr": "<mac:add:ress>",
                        "country": "CZ",
                        "htmode": "VHT20",
                        "channel": "120"
                },
                "interfaces": [
                        {
                                "section": "default_radio0",
                                "config": {
                                        "mode": "ap",
                                        "ssid": "Turris_5",
                                        "hidden": true,
                                        "encryption": "psk2+ccmp",
                                        "wpa_group_rekey": 86400,
                                        "key": "<password>",
                                        "network": [
                                                "lan"
                                        ],
                                        "mode": "ap"
                                }
                        }
                ]
        },
        "radio1": {
                "up": false,
                "pending": false,
                "autostart": true,
                "disabled": true,
                "retry_setup_failed": false,
                "config": {
                        "channel": "36",
                        "hwmode": "11a",
                        "macaddr": "<mac:add:ress>",
                        "htmode": "VHT80",
                        "country": "CZ",
                        "disabled": true
                },
                "interfaces": [

                ]
        }
}

And here are some logs which might help (dont know why timestamps are fuckedup… maybe hostapd is working in UTC):

Aug  9 06:50:51 turris hostapd: wlan0: interface state ENABLED->DISABLED
Aug  9 06:50:51 turris hostapd: wlan0: AP-DISABLED
Aug  9 06:50:51 turris hostapd: wlan0: CTRL-EVENT-TERMINATING
Aug  9 06:50:51 turris hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Aug  9 08:50:51 turris kernel: [1228706.449676] device wlan0 left promiscuous mode
Aug  9 08:50:51 turris kernel: [1228706.454422] br-lan: port 5(wlan0) entered disabled state
Aug  9 06:50:51 turris netifd: Network device 'wlan0' link is down
Aug  9 08:50:53 turris kernel: [1228708.074199] ath10k_pci 0000:00:00.0: No VIF found for vdev 0
Aug  9 08:50:53 turris kernel: [1228708.080362] ath10k_pci 0000:00:00.0: wmi-event-beacon-tx, could not find vdev for id: 0
Aug  9 08:50:55 turris kernel: [1228709.559294] ath10k_pci 0000:00:00.0: WARNING: failed to wait for beacon tx callback for vdev 0: 0
Aug  9 06:50:55 turris hostapd: Configuration file: /var/run/hostapd-phy0.conf
Aug  9 08:50:56 turris kernel: [1228711.250252] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
Aug  9 08:50:56 turris kernel: [1228711.267638] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
Aug  9 08:50:56 turris kernel: [1228711.274011] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
Aug  9 08:50:56 turris kernel: [1228711.282802] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 20904 iram: 26056'
Aug  9 08:50:56 turris kernel: [1228711.349923] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
Aug  9 08:50:56 turris kernel: [1228711.366879] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Aug  9 08:50:56 turris kernel: [1228711.390242] br-lan: port 5(wlan0) entered blocking state
Aug  9 08:50:56 turris kernel: [1228711.395771] br-lan: port 5(wlan0) entered disabled state
Aug  9 08:50:56 turris kernel: [1228711.401635] device wlan0 entered promiscuous mode
Aug  9 06:50:56 turris hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Aug  9 06:50:56 turris hostapd: wlan0: interface state COUNTRY_UPDATE->DFS
Aug  9 06:50:56 turris hostapd: wlan0: DFS-CAC-START freq=5600 chan=120 sec_chan=0, width=0, seg0=0, seg1=0, cac_time=60s
Aug  9 06:52:01 turris hostapd: wlan0: DFS-CAC-COMPLETED success=1 freq=5600 ht_enabled=1 chan_offset=0 chan_width=1 cf1=5600 cf2=0
Aug  9 06:52:01 turris hostapd: Using interface wlan0 with hwaddr <mac:add:ress> and ssid "Turris_5"
Aug  9 08:52:02 turris kernel: [1228776.597213] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Aug  9 08:52:02 turris kernel: [1228776.604342] br-lan: port 5(wlan0) entered blocking state
Aug  9 08:52:02 turris kernel: [1228776.609689] br-lan: port 5(wlan0) entered forwarding state
Aug  9 06:52:02 turris hostapd: wlan0: interface state DFS->ENABLED
Aug  9 06:52:02 turris hostapd: wlan0: AP-ENABLED
Aug  9 06:52:02 turris netifd: radio0 (25330): Command failed: Not found
Aug  9 06:52:12 turris hostapd: wlan0: interface state ENABLED->DISABLED
Aug  9 06:52:12 turris hostapd: wlan0: AP-DISABLED
Aug  9 06:52:12 turris hostapd: wlan0: CTRL-EVENT-TERMINATING
Aug  9 06:52:12 turris hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Aug  9 08:52:12 turris kernel: [1228786.742088] device wlan0 left promiscuous mode
Aug  9 08:52:12 turris kernel: [1228786.746726] br-lan: port 5(wlan0) entered disabled state
Aug  9 06:52:12 turris hostapd: Configuration file: /var/run/hostapd-phy0.conf
Aug  9 08:52:13 turris kernel: [1228788.401066] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
Aug  9 08:52:13 turris kernel: [1228788.418545] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
Aug  9 08:52:13 turris kernel: [1228788.424746] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
Aug  9 08:52:13 turris kernel: [1228788.433363] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 20904 iram: 26056'
Aug  9 08:52:13 turris kernel: [1228788.500313] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
Aug  9 08:52:14 turris kernel: [1228788.516317] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Aug  9 08:52:14 turris kernel: [1228788.526709] br-lan: port 5(wlan0) entered blocking state
Aug  9 08:52:14 turris kernel: [1228788.532589] br-lan: port 5(wlan0) entered disabled state
Aug  9 08:52:14 turris kernel: [1228788.538702] device wlan0 entered promiscuous mode
Aug  9 06:52:14 turris hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Aug  9 06:52:14 turris hostapd: wlan0: interface state COUNTRY_UPDATE->DFS
Aug  9 06:52:14 turris hostapd: wlan0: DFS-CAC-START freq=5600 chan=120 sec_chan=0, width=0, seg0=0, seg1=0, cac_time=60s
Aug  9 06:52:53 turris hostapd: wlan0: DFS-CAC-COMPLETED success=0 freq=5600 ht_enabled=1 chan_offset=0 chan_width=1 cf1=5600 cf2=0
Aug  9 06:52:53 turris hostapd: wlan0: INTERFACE-DISABLED
Aug  9 08:52:53 turris kernel: [1228828.036560] br-lan: port 5(wlan0) entered disabled state
Aug  9 08:52:53 turris kernel: [1228828.089192] device wlan0 left promiscuous mode
Aug  9 08:52:53 turris kernel: [1228828.094034] br-lan: port 5(wlan0) entered disabled state
Aug  9 06:52:53 turris hostapd: Configuration file: /var/run/hostapd-phy0.conf
Aug  9 08:52:54 turris kernel: [1228829.491628] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
Aug  9 08:52:55 turris kernel: [1228829.509099] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
Aug  9 08:52:55 turris kernel: [1228829.515414] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
Aug  9 08:52:55 turris kernel: [1228829.524541] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 20904 iram: 26056'
Aug  9 08:52:55 turris kernel: [1228829.606680] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
Aug  9 06:52:55 turris hostapd: wlan0: INTERFACE-ENABLED
Aug  9 06:52:55 turris hostapd: wlan0: interface state DFS->DFS
Aug  9 06:52:55 turris hostapd: wlan0: DFS-CAC-START freq=5600 chan=120 sec_chan=0, width=0, seg0=0, seg1=0, cac_time=60s
Aug  9 08:52:55 turris kernel: [1228829.623245] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Aug  9 06:52:55 turris hostapd: DFS start_dfs_cac() failed, -1
Aug  9 06:52:55 turris hostapd: wlan0: INTERFACE-DISABLED
Aug  9 06:52:55 turris hostapd: nl80211: Could not configure driver mode
Aug  9 06:52:55 turris hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Aug  9 06:52:55 turris hostapd: nl80211 driver initialization failed.
Aug  9 06:52:55 turris hostapd: wlan0: interface state UNINITIALIZED->DISABLED
Aug  9 06:52:55 turris hostapd: wlan0: AP-DISABLED
Aug  9 06:52:55 turris hostapd: wlan0: CTRL-EVENT-TERMINATING
Aug  9 06:52:55 turris hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Aug  9 06:52:55 turris netifd: radio0 (26225): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 25756 path ()
Aug  9 06:52:55 turris netifd: radio0 (26225): Device setup failed: HOSTAPD_START_FAILED
Aug  9 06:53:05 turris hostapd: Configuration file: /var/run/hostapd-phy0.conf
Aug  9 08:53:06 turris kernel: [1228841.328130] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
Aug  9 08:53:06 turris kernel: [1228841.345596] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
Aug  9 08:53:06 turris kernel: [1228841.352126] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
Aug  9 08:53:06 turris kernel: [1228841.360678] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 20904 iram: 26056'
Aug  9 08:53:06 turris kernel: [1228841.427593] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
Aug  9 06:53:06 turris hostapd: wlan0: INTERFACE-ENABLED
Aug  9 08:53:06 turris kernel: [1228841.446464] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Aug  9 06:53:07 turris hostapd: wlan0: INTERFACE-DISABLED
Aug  9 06:53:07 turris hostapd: nl80211: Could not configure driver mode
Aug  9 06:53:07 turris hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Aug  9 06:53:07 turris hostapd: nl80211 driver initialization failed.
Aug  9 06:53:07 turris hostapd: wlan0: interface state UNINITIALIZED->DISABLED
Aug  9 06:53:07 turris hostapd: wlan0: AP-DISABLED
Aug  9 06:53:07 turris hostapd: wlan0: CTRL-EVENT-TERMINATING
Aug  9 06:53:07 turris hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Aug  9 06:53:07 turris netifd: radio0 (26514): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 25756 path ()
Aug  9 06:53:07 turris netifd: radio0 (26514): Device setup failed: HOSTAPD_START_FAILED
root@turris:/etc# ps -ef | grep hostapd
root     25889     1  0 08:52 ?        00:00:02 /usr/sbin/hostapd -s -P /var/run/wifi-phy0.pid -B /var/run/hostapd-phy0.conf

open “vi” or “vim” or any editor of your choice and change it to ‘0’ in /etc/config/wireless. Once done, issue command uci commit wireless (which is done on background when you hit “save & apply” in Luci). Once done restart the wireless devices using wifi reload.

Problem is, there is no option disabled 1 in following config part where wifi is located:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option macaddr '<mac:add:ress>'
        option country 'CZ'
        option htmode 'VHT20'
        option channel '120'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Turris_5'
        option hidden '1'
        option encryption 'psk2+ccmp'
        option wpa_group_rekey '86400'
        option key '<password>'

sorry for confusion, but as you have ifaces with ‘radio’ in name …

you should have only two “wifi-device” (as you have only two chips/radios), while you can have various “wifi-iface” (where you can have 1 and more “ifaces” serving the AP, AP-Bridge, Relay …Client…whatever you need/want)

notes

each “iface” should be bonded/linked to “device” (device:radio0 is iface:default_radio0 which is hidden=1 -> so not broadcasting SSID at all even if enabled)

ad_disabled: you can have wifi-device or/and wifi-iface with directive option disabled '1' or option disabled '0', if missing it means it is enabled.

as i see you have wifi-device ‘radio1’ disabled in paralled ‘wifi-iface’ ‘default_radio1’ and ‘guest_iface_0’ also disabled. So ‘wifi-device’ ‘radio0’ is enabled while ‘wifi-iface’ ‘default_radio0’ is enabled, but hidden (not broadcasting the SSID). So you should have at least one device and iface up …

aside i am not sure how it si on MOX, but i am missing option path
within ‘wifi-device’ config block (but maybe it is covered by ‘macaddr’ , )
for example my radio0 >> option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'

common option for device(s)

macaddr MAC address yes/no (autodetected) Specifies the radio adapter associated to this section, it is not used to change the device mac but to identify the underlying interface.

common options for ifaces

macaddr mac address no (hostapd/driver default) Overrides the MAC address used for the Wi-Fi interface. Warning: if the MAC address specified is a multicast address, this override will fail silently. To avoid this problem, ensure that the mac address specified is a valid unicast mac address.

tbh: so i am not sure if you should put macaddr also to wifi-iface config block accordingly or not (or removing it from wifi-device section … (as i am Omnia owner my wirells might be different in terms of ‘uci config’ options used (required, optional…).

… here is my config , two AP (one hidden) and one guest-AP:

wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option country 'CZ'
        option hwmode '11a'
        option path '<path to hw device>'
        option htmode 'VHT80'
        option txpower '23'
        option channel '36'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'MYSSID'
        option encryption 'psk2+tkip+aes'
        option key '<mypassword>'
        option hidden '0'
        option wpa_group_rekey '86400'

config wifi-device 'radio1'
        option type 'mac80211'
        option country 'CZ'
        option hwmode '11g'
         option path '<path to hw device>'
        option htmode 'HT40'
        option channel 'auto'
        option txpower '19'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'MYSSID2'
        option encryption 'psk2+tkip+aes'
        option key '<mypassword>'
        option hidden '0'
        option wpa_group_rekey '86400'

config wifi-iface 'guest_iface_1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'GUESTSSID'
        option encryption 'psk2+tkip+aes'
        option key '<gust_password>'
        option ifname 'guest_turris_1'
        option network 'guest_turris'
        option isolate '1'

Yep, and wifi status is showing:

{
        "radio0": {
                "up": false,

So I dont understand why restart of device is not working… also dont know how to find if its HW issue or not… anyway… going to restart whole network which helps… and if this happen again… we can continue debugging…

Btw… we can try to add the path, but I have no idea how to find which path I should use…

# lspci
00:00.0 Network controller: Qualcomm Atheros QCA986x/988x 802.11ac Wireless Network Adapter

So I tried to restart and wifi on Qualcomm still doesnt work… I tried to setup wifi on Marwell and that is up :slight_smile:

Aug  9 13:58:18 turris hostapd: Configuration file: /var/run/hostapd-phy0.conf
Aug  9 15:58:19 turris kernel: [1254351.483322] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
Aug  9 15:58:19 turris kernel: [1254351.501021] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
Aug  9 15:58:19 turris kernel: [1254351.507402] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
Aug  9 15:58:19 turris kernel: [1254351.516407] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 20904 iram: 26056'
Aug  9 15:58:19 turris kernel: [1254351.584715] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
Aug  9 15:58:19 turris kernel: [1254351.604540] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Aug  9 13:58:19 turris hostapd: wlan0: INTERFACE-ENABLED
Aug  9 13:58:19 turris hostapd: wlan0: INTERFACE-DISABLED
Aug  9 13:58:19 turris hostapd: nl80211: Could not configure driver mode
Aug  9 13:58:19 turris hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Aug  9 13:58:19 turris hostapd: nl80211 driver initialization failed.
Aug  9 13:58:19 turris hostapd: wlan0: interface state UNINITIALIZED->DISABLED
Aug  9 13:58:19 turris hostapd: wlan0: AP-DISABLED
Aug  9 13:58:19 turris hostapd: wlan0: CTRL-EVENT-TERMINATING
Aug  9 13:58:19 turris hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Aug  9 13:58:19 turris netifd: radio0 (29901): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 25119 path ()
Aug  9 13:58:19 turris netifd: radio0 (29901): Device setup failed: HOSTAPD_START_FAILED 

And looks like I hit most probably this bug - https://bugs.openwrt.org/index.php?do=details&task_id=3018&order=id&sort=desc … but strange is, that radio1 is working…

So… during the night even second wifi went down :-/

{
        "radio0": {
                "up": false,
                "pending": false,
                "autostart": true,
                "disabled": false,
                "retry_setup_failed": true,
                "config": {
                        "macaddr": "<mac:add:ress>",
                        "country": "CZ",
                        "channel": "auto",
                        "hwmode": "11g",
                        "htmode": "NOHT",
                        "disabled": false
                },
                "interfaces": [
                        {
                                "section": "default_radio0",
                                "config": {
                                        "mode": "ap",
                                        "encryption": "psk2+ccmp",
                                        "wpa_group_rekey": 86400,
                                        "key": "<password>",
                                        "hidden": false,
                                        "ssid": "Turris_2",
                                        "network": [
                                                "lan"
                                        ],
                                        "mode": "ap",
                                        "disabled": false
                                }
                        }
                ]
        },
        "radio1": {
                "up": true,
                "pending": false,
                "autostart": true,
                "disabled": false,
                "retry_setup_failed": false,
                "config": {
                        "channel": "36",
                        "hwmode": "11a",
                        "macaddr": "<mac:add:ress>",
                        "htmode": "VHT80",
                        "country": "CZ",
                        "disabled": false
                },
                "interfaces": [
                        {
                                "section": "default_radio1",
                                "ifname": "wlan1",
                                "config": {
                                        "mode": "ap",
                                        "key": "<password>",
                                        "ssid": "Turris_5",
                                        "encryption": "psk2+tkip+ccmp",
                                        "hidden": false,
                                        "wpa_group_rekey": 86400,
                                        "network": [
                                                "lan"
                                        ],
                                        "mode": "ap",
                                        "disabled": false
                                }
                        }
                ]
        }
}

Aug 10 00:25:52 turris kernel: [1284801.755723] mwifiex_sdio mmc0:0001:1: mwifiex_sdio_card_to_host: invalid packet, nb=32974 npayload=256
Aug 10 00:25:52 turris kernel: [1284801.765721] mwifiex_sdio mmc0:0001:1: mwifiex_process_int_status: failed to card_to_host
Aug 10 00:26:02 turris kernel: [1284811.621844] mwifiex_sdio mmc0:0001:1: mwifiex_cmd_timeout_func: Timeout cmd id = 0xd0, act = 0xdc00
Aug 10 00:26:02 turris kernel: [1284811.631668] mwifiex_sdio mmc0:0001:1: num_data_h2c_failure = 0
Aug 10 00:26:02 turris kernel: [1284811.638005] mwifiex_sdio mmc0:0001:1: num_cmd_h2c_failure = 0
Aug 10 00:26:02 turris kernel: [1284811.644285] mwifiex_sdio mmc0:0001:1: is_cmd_timedout = 1
Aug 10 00:26:02 turris kernel: [1284811.650011] mwifiex_sdio mmc0:0001:1: num_tx_timeout = 0
Aug 10 00:26:02 turris kernel: [1284811.655829] mwifiex_sdio mmc0:0001:1: last_cmd_index = 0
Aug 10 00:26:02 turris kernel: [1284811.661556] mwifiex_sdio mmc0:0001:1: last_cmd_id: d0 00 b0 00 b0 00 b0 00 d0 00
Aug 10 00:26:02 turris kernel: [1284811.669423] mwifiex_sdio mmc0:0001:1: last_cmd_act: 00 dc 01 00 01 00 01 00 00 1c
Aug 10 00:26:02 turris kernel: [1284811.677200] mwifiex_sdio mmc0:0001:1: last_cmd_resp_index = 4
Aug 10 00:26:02 turris kernel: [1284811.683407] mwifiex_sdio mmc0:0001:1: last_cmd_resp_id: b0 80 b0 80 b0 80 b0 80 d0 80
Aug 10 00:26:02 turris kernel: [1284811.691794] mwifiex_sdio mmc0:0001:1: last_event_index = 4
Aug 10 00:26:02 turris kernel: [1284811.697394] mwifiex_sdio mmc0:0001:1: last_event: 33 00 33 00 37 00 37 00 37 00
Aug 10 00:26:02 turris kernel: [1284811.705428] mwifiex_sdio mmc0:0001:1: data_sent=0 cmd_sent=0
Aug 10 00:26:02 turris kernel: [1284811.711479] mwifiex_sdio mmc0:0001:1: ps_mode=1 ps_state=0
Aug 10 00:26:02 turris kernel: [1284811.719079] mwifiex_sdio mmc0:0001:1: ===mwifiex driverinfo dump start===
Aug 10 00:26:02 turris kernel: [1284811.726172] mwifiex_sdio mmc0:0001:1: info: MWIFIEX VERSION: mwifiex 1.0 (16.68.1.p197)
Aug 10 00:26:02 turris kernel: [1284811.734918] mwifiex_sdio mmc0:0001:1: SDIO register dump start
Aug 10 00:26:02 turris kernel: [1284811.741031] mwifiex_sdio mmc0:0001:1: SDIO Func0 (0x0-0x9): 43 03 06 06 07 00 00 02 03 00
Aug 10 00:26:02 turris kernel: [1284811.749885] mwifiex_sdio mmc0:0001:1: SDIO Func1 (0x10-0x17): 00 00 20 00 ff 00 f0 ff
Aug 10 00:26:02 turris kernel: [1284811.758298] mwifiex_sdio mmc0:0001:1: SDIO Func1: (0x8) c3 (0x58) 00 (0x5c) 08 (0x5d) 00 (0x60) 07 (0x61) 0c (0x62) 00 (0x64) 10 (0x65) 00 (0x66) 00 (0x68) 00 (0x69) 00 (0x6a) 00
Aug 10 00:26:02 turris kernel: [1284811.775027] mwifiex_sdio mmc0:0001:1: SDIO Func1 (0xe8-0xf2): dc fe 1c 00 b4 00 3f 94 94 01 70
Aug 10 00:26:02 turris kernel: [1284811.884581] mwifiex_sdio mmc0:0001:1: SDIO Func1 (0xe8-0xf2): dc fe 2b 00 bf 00 3f 94 94 01 70
Aug 10 00:26:02 turris kernel: [1284811.893503] mwifiex_sdio mmc0:0001:1: SDIO register dump end
Aug 10 00:26:02 turris kernel: [1284811.899932] mwifiex_sdio mmc0:0001:1: ===mwifiex driverinfo dump end===
Aug 10 00:26:02 turris kernel: [1284811.906842] mwifiex_sdio mmc0:0001:1: == mwifiex firmware dump start ==
Aug 10 00:26:02 turris kernel: [1284811.936502] mwifiex_sdio mmc0:0001:1: Fail to pull ctrl_data
Aug 10 00:26:02 turris kernel: [1284811.942538] mwifiex_sdio mmc0:0001:1: firmware dump failed
Aug 10 00:26:02 turris kernel: [1284811.948308] mwifiex_sdio mmc0:0001:1: == mwifiex dump information to /sys/class/devcoredump start
Aug 10 00:26:02 turris kernel: [1284811.957985] mwifiex_sdio mmc0:0001:1: == mwifiex dump information to /sys/class/devcoredump end
Aug 10 00:26:02 turris kernel: [1284811.967297] mwifiex_sdio mmc0:0001:1: PREP_CMD: FW is in bad state
Aug 10 00:26:02 turris kernel: [1284811.974416] mwifiex_sdio mmc0:0001:1: info: shutdown mwifiex...
Aug 10 00:26:02 turris kernel: [1284811.980887] mwifiex_sdio mmc0:0001:1: mwifiex_cfg80211_change_beacon: setting mgmt ies failed
Aug  9 22:26:02 turris hostapd: Failed to set beacon parameters
Aug 10 00:26:02 turris kernel: [1284811.990624] mwifiex_sdio mmc0:0001:1: PREP_CMD: card is removed
Aug 10 00:26:02 turris kernel: [1284811.996759] mwifiex_sdio mmc0:0001:1: Failed to delete mgmt IEs!
Aug 10 00:26:02 turris kernel: [1284812.003364] mwifiex_sdio mmc0:0001:1: PREP_CMD: card is removed
Aug 10 00:26:02 turris kernel: [1284812.009326] mwifiex_sdio mmc0:0001:1: Failed to stop the BSS
Aug  9 22:26:02 turris netifd: Network device 'wlan1' link is down
Aug 10 00:26:02 turris kernel: [1284812.016828] br-lan: port 5(wlan1) entered disabled state
Aug 10 00:26:02 turris kernel: [1284812.025633] device wlan1 left promiscuous mode
Aug 10 00:26:02 turris kernel: [1284812.030354] br-lan: port 5(wlan1) entered disabled state
Aug 10 00:26:02 turris kernel: [1284812.042371] mwifiex_sdio mmc0:0001:1: PREP_CMD: card is removed
Aug 10 00:26:02 turris kernel: [1284812.048544] mwifiex_sdio mmc0:0001:1: PREP_CMD: card is removed
Aug 10 00:26:02 turris kernel: [1284812.054972] mwifiex_sdio mmc0:0001:1: PREP_CMD: card is removed
Aug  9 22:26:02 turris hostapd: wlan1: AP-STA-DISCONNECTED <mac:add:ress1>
Aug  9 22:26:02 turris hostapd: wlan1: AP-STA-DISCONNECTED <mac:add:ress2>
Aug  9 22:26:02 turris hostapd: wlan1: AP-STA-DISCONNECTED <mac:add:ress3>
Aug  9 22:26:02 turris hostapd: wlan1: INTERFACE-DISABLED
Aug 10 00:26:02 turris kernel: [1284812.305031] sdio_read_cccr card report SDIO_UHS_DDR50
Aug 10 00:26:02 turris kernel: [1284812.310469] sdio_read_cccr card report SDIO_UHS_SDR50
Aug 10 00:26:02 turris kernel: [1284812.315886] sdio_read_cccr card report SDIO_UHS_SDR104
Aug 10 00:26:04 turris kernel: [1284813.388724] mwifiex_sdio mmc0:0001:1: info: FW download over, size 623240 bytes
Aug 10 00:26:04 turris kernel: [1284814.231768] mwifiex_sdio mmc0:0001:1: WLAN FW is active
Aug  9 22:26:08 turris hostapd: Failed to set beacon parameters
Aug  9 22:26:14 turris hostapd: Failed to set beacon parameters
Aug 10 00:26:15 turris kernel: [1284824.420645] mwifiex_sdio mmc0:0001:1: mwifiex_cmd_timeout_func: Timeout cmd id = 0xa9, act = 0x0
Aug 10 00:26:15 turris kernel: [1284824.429965] mwifiex_sdio mmc0:0001:1: num_data_h2c_failure = 0
Aug 10 00:26:15 turris kernel: [1284824.436275] mwifiex_sdio mmc0:0001:1: num_cmd_h2c_failure = 0
Aug 10 00:26:15 turris kernel: [1284824.442473] mwifiex_sdio mmc0:0001:1: is_cmd_timedout = 1
Aug 10 00:26:15 turris kernel: [1284824.448218] mwifiex_sdio mmc0:0001:1: num_tx_timeout = 0
Aug 10 00:26:15 turris kernel: [1284824.454008] mwifiex_sdio mmc0:0001:1: last_cmd_index = 1
Aug 10 00:26:15 turris kernel: [1284824.459743] mwifiex_sdio mmc0:0001:1: last_cmd_id: d0 00 a9 00 b0 00 b0 00 d0 00
Aug 10 00:26:15 turris kernel: [1284824.467662] mwifiex_sdio mmc0:0001:1: last_cmd_act: 00 dc 00 00 01 00 01 00 00 1c
Aug 10 00:26:15 turris kernel: [1284824.475591] mwifiex_sdio mmc0:0001:1: last_cmd_resp_index = 4
Aug 10 00:26:15 turris kernel: [1284824.481646] mwifiex_sdio mmc0:0001:1: last_cmd_resp_id: b0 80 b0 80 b0 80 b0 80 d0 80
Aug 10 00:26:15 turris kernel: [1284824.489939] mwifiex_sdio mmc0:0001:1: last_event_index = 4
Aug 10 00:26:15 turris kernel: [1284824.495837] mwifiex_sdio mmc0:0001:1: last_event: 33 00 33 00 37 00 37 00 37 00
Aug 10 00:26:15 turris kernel: [1284824.503615] mwifiex_sdio mmc0:0001:1: data_sent=1 cmd_sent=1
Aug 10 00:26:15 turris kernel: [1284824.509740] mwifiex_sdio mmc0:0001:1: ps_mode=0 ps_state=0
Aug 10 00:26:15 turris kernel: [1284824.515734] mwifiex_sdio mmc0:0001:1: info: _mwifiex_fw_dpc: unregister device
Aug  9 22:26:20 turris hostapd: Failed to set beacon parameters
Aug  9 22:26:26 turris hostapd: Failed to set beacon parameters
Aug  9 22:26:32 turris hostapd: Failed to set beacon parameters
Aug  9 22:26:38 turris hostapd: Failed to set beacon parameters
Aug  9 22:26:44 turris hostapd: Failed to set beacon parameters
Aug  9 22:26:50 turris hostapd: Failed to set beacon parameters
Aug  9 22:26:56 turris hostapd: Failed to set beacon parameters
Aug  9 22:27:02 turris hostapd: Failed to set beacon parameters
Aug  9 22:27:08 turris hostapd: Failed to set beacon parameters
Aug  9 22:27:14 turris hostapd: Failed to set beacon parameters
Aug  9 22:27:20 turris hostapd: Failed to set beacon parameters
Aug  9 22:27:26 turris hostapd: Failed to set beacon parameters
Aug  9 22:27:32 turris hostapd: Failed to set beacon parameters

and since then this error is there all the time.

TBH: now i am bit of lost … i would try to apply medikit + update to latest version and if that won’t work
. i would raise a ticket to technical support.

Tell me about it…

OK, I will check how to do it and try it :slight_smile:

But thanks for support!

https://docs.turris.cz/hw/mox/rescue_modes/
i would try mode#3 , if that won’t work , try mode#6 (or #4 if you download the medikit manually).

some notes ...

Aside i’ve notice several post from other users complaining about the wifi in general (not working, frequent disassociated clients vs dhcp release, unstable AP …). One user mentioned , that after upgrade to 5.x branche , there was forced migration step of UCI config in Luci/Wireless. Which might be somehow messed (some stuff in 3.x branche is defined , but in 5.x it seems some stuff is autodetected during boot and/or during init of device/iface). So i would give a try to get default/template of uci wireless config for MOX (your TOS branche) and try to set it manually. If you look at that openwrt wiki page for uci-wireless(linked somewhere above) , there are some directives having “autodetect” or “yes/no” in column identifying the “default” value.

If you are going to experiment, maybe you can try different firmware for ath10k, there are
ath10k-firmware-qca988x regular
ath10k-firmware-qca988x-ct alternative from CandelaTech.

ad_autodetect

when i was having some issues(kernel params, wifi) i found that initial “kernel.log” buffer has short life, once syslog-ng hits in, buffer is overwriten with latest buffer and in few minutes you won’t see the boot-up messages anymore …

To capture boot info into persistent file i have this in /etc/rc.local
## catch boot log to separate file
echo "====[dmesg]====" > /srv/logs/boot.log && dmesg >> /srv/logs/boot.log
So i can inspect it later on :), + i have /etc/logrotate.d/boot set up, so i have last 7 boot.logs saved.

I actually tried factory reset months ago, because I was having issues with wifi before already. I will try #6 hopefully this week and lets see… but having this router as main is a bit pain (mainly for money which it cost :-/)

Ok… #6 is done, so lets see how long Wifi will be up and running :slight_smile:

So it took 5 days and 5GHz Wifi is down… going to create a ticket to support.

I also had about a week with my new Turris MOX before it’s 5GHz wifi broke.
I literally bought a MOX since the 5GHz wifi on my Omnia broke.