MOX connectivity problem - cannot connect to MOX


this is my MOX-setup:

  • MOX A with SDIO WiFi and 8GB Kingston microSD
  • MOX B with WLE900VX installed

I had this MOX already running without any problems around 2 months ago but didn’t have the time to play with it since. Yesterday I booted it up again but it is not responsive any more:

  • MOX A LED blinks in heartbeat-pattern showing it booted well, MOX B LED #2 is permanently on
  • it has no DHCP-server running. Running Wireshark it doesn’t show any activity.
  • Setting my PC’s NIC to static IP with netmask I cannot ping it. Running Wireshark it doesn’t show any activity.

That said I took the microSD-card and reformatted it according to But unfortunately that didn’t help me any further, my MOX still shows the very same behaviour :frowning:

Has anyone an idea how to troubleshoot his?


Your description is too simple. Are you sure you boot into Mode 4 or 3, depending on how you prepared the SD card? Then you have to connect the PC via LAN ethernet on MOX and manually enter the ip for PC. Simply do all steps like turn on mox for the first time. Have you tried SD card after formatting? mount into another linux system?

1 Like

My bad - it seems my PC’s NIC is somehow corrupt. I just tried another NIC and it worked right away.
Thread can be closed.