Mounting HFS+ USB drive

I am trying to mount a HFS+ USB drive to build a Time Machine volume as per

Unfortunately, I can only get it to mount read-only. Any ideas on how to mount it rw?

1 Like

You’ll need to disable journaling on the drive first (when connected to a Mac system).

On the other hand, you do not need to use HFS+ in order for Time Machine to work, any regular filesystem should work, as long as exposed via Netatalk properly.

Journaling had been turned off, that’s not the problem.

In the meantime I found out that the drive mounts ro on Turris’ back USB port and rw on the front USB port. The behaviour is repeatable. How’s that possible? / How can I get the back USB port to mount rw?

Also, the next problem came up when connected to Turris’ front port. I’ve got two Macs. Mac 1 does a backup just fine, Mac 2 terminated after a coupkle of minutes with error code “null”. While Mac 1 immediately creates a .sparsbundle file when it starts the backup, Mac two first creates a .tmp file and doesn’t get any further.

So, I got TimeMachine working by formatting the USB drive FAT32 instead. That seems to run stable for the last two days. However, that doesn’t solve the erratic behavior of mounting HFS+ between the two USB ports.
I’ve formatted another drive (USB stick to be exact) HFS+, turned off journaling and couldn’t mount it rw on either port.

Apparently, others are seeing similar issues: Mount read-write HFS+ drive in OpenWRT

Where can I load the required modules Netatalk, Avahi (as described in howto/timemachine)?

I instealled them w/ opkg. However, it seems like they removed some packes. I continously keep getting “Updater failed: inconsistent: Package avahi-daemon is not available” now.
I guess you’d need to ask them why the package was removed.

Ok, you have to run “opkg - update” first, then you can install the modules with “opkg - install”. I have entered the configuration according to Wiki, but I get on the MAC with macOS Sierra no display from the hard drive. In the system log I have seen the AFP was bound to the WAN interface. I changed in the afpd.conf the interface with “-ipaddr”. Now there are no error messages in the system log, but also no display on my MAC …

now it works! I have entered on the MAC in the Finder “AFP: //” then User “tmuser” and Password. Now I can see the volume on the MAC!