Mount read-write HFS+ drive in OpenWRT

I’m attempting to re-purpose a SSD drive that has been formatted HFS+.

While I’ve been able to mount the drive:

root@turris:/# mount -t hfsplus /dev/sda2 /mnt/jetdrive 

It’s read-only:

root@turris:/mnt# touch /mnt/jetdrive foobar
touch: /mnt/jetdrive: Read-only file system

I’ve tried to force the setting, but it doesn’t work:

root@turris:/mnt# mount -t hfsplus -o remount,rw /dev/sda2 /mnt/jetdrive
mount: /mnt/jetdrive not mounted or bad option

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

This thread suggests installing hfsprogs, but it’s not in opkg:

root@turris:/mnt# opkg install hfsprogs
Unknown package 'hfsprogs'.
Collected errors:
 * opkg_install_cmd: Cannot install package hfsprogs.

Is there another way to get this to work? Using OS X’s Disk Utility in 10.21.1 doesn’t seem to offer a way to remove Journaling.

1 Like

You can turn off journaling using OS X command line: diskutil disableJournal /Volumes/NAME.

However, that didn’t solve the ro problem for me. I tried two drives. One would only mount rw on the front USB port, the other would only mount ro on both ports. I have no explanation for that: Mounting HFS+ USB drive

Thanks for the reply. I decided to format the drive as ext3, which appears to work fine.

I tried ext4, but I was having difficultly transferring large files to it.

You need packages hfsfsck and kmod-fs-hfsplus and maybe mkhfs, there is no package hfsprogs.

And to mount hfsplus rw you need -o force,rw

It is written in dmesg when you try to mount without it. No need to remove the journalling.

1 Like

The force,rw option did the trick.

USB device (Sandisk MicroSD) is read/write in both USB ports.

I have hfsfsck, kmod-fs-hfs, kmod-fs-hfsplus, mkhfs, and sshfs installed.