miniDLNA not refreshing

Hi, I have bought Turris Omnia and I am trying to set up miniDLNA. I have external drive connected and mounted to /srv. In /srv/NAS I have direcory which is accesed by SMB (that works). In /srv/NAS/Share/Media I have folder which is configured in miniDLNA. Everything works good. But when I add any file (via SMB) the file is not automatically indexed by miniDLNA. /etc/init.d/minidlna reload does not help. Only thing that helps is rebooting whole router. I have inotify option turned on in miniDLNA settings.

How can I set up to automatically detect new files? Rebooting everytime is pretty annoying.

Perhaps restarting the service is OK for you?

/etc/init.d/minidlna restart

I know nothing about minidlna in particular, really.

Restart works but only when I delete database directory before. But that is pretty anoing as well. I don’t want to manually restart or delete something everytime I add a file.

I used this workaround: I have installed LXC container with debian and downloaded miniDLNA from apt-get and configured it manually. Now everything works. The miniDLNA version in OpenWrt has probably a bug which causes that sometimes the library is not being refreshed.

I have the same issue. It seems that the latest version of minidlna (installed by the package manager) isn’t compatible with the current version of Turris’ OX (v3?).

I have to do the following to reindex content:

# rm -rf /var/run/minidlna
# /etc/init.d/minidlna restart

On a related note, do you receive error messages about running a LXC container from the internal memory (bad)? I have a container installed on an internal RAID driver, but I still get this message.

Yes, I thing there is some bug somewhere in miniDLNA/Turis.

Ad LXC on internal storage:
I once also got a warning not to run LXC container in internal memory. I was because the storage menu item in Foris is not working properly. It had formatted my drive into Btrfs filesystem, but it hadn’t mount it as /srv. In the storage menu item I still had red warning that the internal storage is used. I had to mount it manually in LuCI as /srv:

This website didn’t allow me to insert two images in one post, so:

Now the Storage menu item in Foris is green, which hadn’t been.

Mohu potvrdit stejné chování i u Turisu 1.1 - pro aktualizaci seznamu souborů je potřeba smazat databázi a restartovat službu a tím vytvořit databázi novou. :frowning:

Does it happens also on Turris OS 4.x/5.x?

I am having this issue on Turris OS 3.11.5.

Is there any viable solution for this bug? I have similar problem, although not exactly the same - in my case, Turris is not refreshing and showing only large files (over few GB, did not tinkered with determining exact size). And the restart of Turris helps (when reindexing is executed automatically). But this is not sufficient, since I want to use it without any complications, and waiting 30 mins until all my library is refreshed to see newly added movie which I want to watch with my wife is definitely a complication for me…

Basic infos -> model: Turris Omnia, FW version: OpenWrt omnia 15.05 r47055, Core: 4.4.196, minidlna: 1.2.1.

Extended infos -> minidlna is running over HDD with ext4, mounting configured through LuCi. Minidlna configured also through LuCi, and there is noting special:

Any ideas?

Maybe is better solution move the database from /var (= space limited RAM) to /mnt/hdd1 .

thanks for tip, unfortunately, did not helped. But at least, it had some effect - stopped refreshing entirely (what is of course, not good, but at least something changed…) -> simply after adding new file, or event after restart of Turris, new file was not detected at all… any other tips? Maybe someone who does not have any problems with DLNA?

I have in the settings, attached the media directory at the end of the path “/” . Try this.

My version of software is same, but not hardware. I have Turris 1.1 = different procesor.