miniDLNA not autostarting after each update

I’ve set miniDLNA to start automatically, but every time the router updates (at least since 3.7.4), the miniDLNA service is still checked as autostarted in Luci, but it doesn’t start automatically. Starting it manually works. Nothing in the system log matches “dlna”.

What should I do to have it really autostart?

And also, is there a way to stop it reindexing all files when I start the service? My DB directory is set to /tmp/run/mountd/sda1/video, which is a permanent storage (and also the drive being indexed).

After update to 3.8.3, the status of the service is “enabled”:

# /etc/init.d/minidlna enabled && echo enabled

but the service did not autostart.

We are seeing this problem since version 2.7.

My guess is that it’s because of slow network setup on my Omnia.

@commar can you confirm you also have “slower than usual” network setup?

Aha, finally I managed to get some debug output from minidlna at boot, and the issue is a bit different, but I’d say also similar:

[2018/01/17 03:08:34] utils.c:279: warn: make_dir: cannot create directory '/tmp/run/mountd/sda1/'
[2018/01/17 03:08:35] minidlna.c:658: fatal: Database path not accessible! [/tmp/run/mountd/sda1/video]

So instead of waiting for network interface, we have to wait for the device where db_dir resides.

1 Like